Octopi doesn't connect to wifi

Greetings! I installed OctoPi on my RPi 4, then changed the wpa supplicant txt file to my wifi settings, but when I plug it in and try to open the web browser, nothing, I made sure the IP was correct by using Advanced IP Scanner, didn't show. I uncommented the 4 hashtags (or pounds if you prefer) btw. I don't know what's wrong, but if I can't get OctoPi set up, I might use it as RetroPie.

What version of OctoPi? How did you image the SD card? If you used the Raspberry Pi Imager, then you can use the gear icon to set the WiFi settings before you write the image onto the SD card.

Can you post (or upload) your /boot/octopi-wpa-supplicant.txt file here? You can obfuscate the psk and ssid carefully and use the </> tool if you post the contents instead of uploading the file.

If you can use an ethernet cable instead the defaults on the RPi should get you up on the network so you can SSH in and troubleshoot the WiFi connection.

One question, is the WPA supplicant file supposed to have a string in the psk?

## WPA/WPA2 secured
country=US # United States

Do I just copy that into WPA and swap out the ssid and psk?

You can do that or edit the one you have making sure it looks like mine. Note that the "country=US" line is not next to the "## WPA/WPA2 secured section" (but it can be if you want).

Make sure when you edit that you don't change the line endings. I use Notepad++ on my Windows desktop and make sure the line endings are set to Unix (LF). If you are using Windows 10 and it is updated, then Notepad now preserves line endings.

Of course, you can edit the file on the RPi using nano, vi, or emacs (which you may have to install).

You can take a look at this thread:

It runs through a lot of the common problems people have in getting their Pi or OctoPi setup onto their WiFi network.

It was written some time ago, but most (all?) of the troubleshooting stuff should still apply.

Ok, I set the wifi country. Now it's visible on Advaced IP but when i enter the ip in edge.

I feel like there is missing something in your last sentence

oh sorry, when I enter the ip in edge, nothing.

Can you share a screenshot of edge when you try?



No and no, the https url just says the same, http doesnt add the http, same outcome

Is the rpi 4 compatible with 5G?

@Ewald_Ikemann Ok, I tried enabling "show dead" on Advaced IP, it shows the rpi, but it's dead, at least the scanner says it is, is there a fix?

5Ghz wifi - yes

Ok, I think the reason I see it but can't connect is that it says it's dead, can I fix that?

Ok, this is really annoying. I could see it but not connect, because the password's ending quote had been deleted, must have pressed backspace by accident.

1 Like

I'm having the same issues. Went through a slew of help articles including Octoprint's Q&A for WiFi Troubleshooting. I tried flashing with Pi Imager and Balena Etcher. I can't get WiFi to connect. On RPB 4B connecting to 2.4 Ghz. Manually updated wpa-supplicant.txt and had it written with Pi Imager. I connected via ethernet for now but eventually would want to get rid of a 20ft ethernet cable running across my room.

One thing odd I noticed was after I flashed and opened my wpa-supplicant.txt file the password field was a bunch of random number strings with no " around the password.

I don't know. I spent the last 2 days trying to fix this. Even bought a new microSD card. This is dumb.