Octopi/Octoprint deleting wifi and log files!

What is the problem?

Octoprint Log and wifi files (maybe others) are vanishing so I keep having to re-flash my memory card, almost weekly.

What did you already try to solve it?

I have no clue what's causing it, so no idea what to do to fix it.

Have you tried running in safe mode and if so did it solve the issue?

Safe mode won't return missing files.

Complete Logs

there is no log. As stated above, Log and wifi files are just gone.

Additional information about your setup

[Vilros Raspberry Pi 4 Basic Starter Kit with Fan-Cooled Heavy-Duty Aluminum Alloy Case (2GB, Black) connected to an Ender 3 Pro.

How do you know the files are missing? Can you ssh to the pi? How do you initially set the files up?

There's a LOT more detail that's missing here.

  1. I know the files are missing when I can't connect to my Pi over wifi. I retrieve the sd card, plug it into my computer and yeah, they're gone.
  2. I've never messed with SSH, and seeing as how the files that tell the Pi to connect to wifi are gone, I don't think it'd work.
  3. I initially set the files up by flashing "2019-09-26-octipi-buster-lite-0.17.0.img" to my SD Card with balenaEtcher, as described in the instructions on the download page. I then go in and edit the wifi file to connect. Plug the card into the Pi, run the initial setup, and proceed to printing. Then, after a week or so, my webcam (logitech 920(?)) stops working, so I reboot the Pi through the Octopi interface. Suddenly it won't connect, and I know the files are gone.

Assuming you are adding the files to /boot/, like /boot/wpa_supplicant.txt, they are moved as it initially starts.

moved where? Why would the files be moved on reboot to where I can't connect? The wpa_supplicant is nowhere on the sd card when this happens. It's gone.

Assuming you're plugging the card into a windows machine, it cannot see the full filesystem (only /boot). You will need to look at it either via SSH, connect a monitor to the Pi or put the SD card in another Linux box.

Keep in mind that holds only true for the Rasbian wpa-supplicant stuff, not for OctoPi's approach of configuration through octopi-wpa-supplicant.txt. That does NOT get moved.

In general, if stuff is really vanishing, this sounds like a broken file system. If you are in the habit of simply powering down the Pi without shutting it off first through the menu, stop doing that.

No, I shut the system down or reboot through the Octoprint browser interface. Also, it IS the octopi-wpa-supplicant.txt that goes missing.

In that case, all I can recommend is to run a file system check and maybe switch to another SD card.

OctoPrint cannot remove that file (it doesn't have the necessary rights), and there's nothing in OctoPi that would make it get removed either. So if it's vanishing, something's up with the file system or the SD. It certainly is not normal behaviour.

How do I run a system check? The SD was brand new when I started using it, and I don't think I have another that's big enough for an Octoprint install, and no money for a new one right now.

True. I forget about the difference in behavior.

OP really needs to ssh and explore. Something else is happening.

SD cards are what, $8?

What OS do you have that you are using to 'burn' the SD card?

First, it's not your job to judge my budget. That being said, I've been unemployed since January, so money is tight. My 3d printer is optional at the moment, so what money I have is going elsewhere.


Would you, or someone who knows, kindly link or explain how to SSH from Win10 to do this?

Download and install PuTTY on your Windows 10 machine. When your start PuTTY, it wants the host name or the IP address of your RPi. If you haven't changed the hostname on the RPi, the default is octopi or octopi.local. If those fail, connect to the web interface of your router and look for the DHCP server page which should list the IP addresses it has handed out.

PuTTY will open a command terminal on your Windows 10 desktop asking for the username which unless you changed it should be pi and the password would be what you changed it to from the default of raspberry.

An alternate method for looking at the root file system on the RPi is to use WinSCP. You use the same information (host name or IP address, username, password) with the protocol SFTP.

Let us know if this explanation isn't sufficient. As part of your 3D printing experience with OctoPi / OctoPrint, you will have to learn a few Linux commands. People here are pretty good about providing the commands they want the output of to help solve your problems.


This person is asking for help not uncalled for judgement. Where I live sd cards cost around $20 which is the cost of a meal.

1 Like

This is a good and useful explanation of what is required to troubleshoot his problem. What I don't understand as a 'recreational 3D printer user' (until March anyway when I began printing my 1200 'earsavers' for local health units) why it is that users of Octopi should need to know any linux commands. Since Windows was released about 30 years ago I have never really needed to issue a DOS command and I use dozens of programs. It would seem to me that there are people in this community who enjoy digging deeply into computer control just as some folk enjoy taking their car engines part while some of us just want to drive from A to B. The 'daily drivers' should not be frowned upon for not being 'techies' in my opinion.

Perhaps "you will have to learn a few Linux commands" was a bit judgemental. Maybe I should have said "we would like you to learn a few Linux commands" so that together we can get to the cause of the problem you came here hoping we could solve.

Windows did revolutionize the computer industry. Linux has also become a very popular operating system. It or other Unix variants are embedded in many devices we use today including most cell phones and in many of those devices, there is no need to access or use the shell commands.

The Raspberry Pi is a single board computer (SBC) that utilizes a system on a chip (SOC) but is powerful enough to run a windows-like GUI if the user so chooses but that comes with a cost. To avoid that overhead, lite versions of Linux allow for the resources of the RPi to be dedicated to specific tasks like being a front-end for a 3D printer but to do so, they sacrifice the GUI.

If the 3D printer behaves (by both design and reliability), then there is little need for access to the RPi at the shell (command) level. OctoPrint provides access to the printer via a web browser.

Unfortunately, not all 3D printers behave. Some misbehave because of poor design, others are unreliable, and sometimes they just break. When the owners of these misbehaving 3D printers come here for help, us helpers may need to use tools much as a mechanic at an auto repair shop would with one big exception, we don't have the luxury of putting our hands on the patient. Those asking for help need to get their hands "dirty" and knowing which end of the "screwdriver" to use is essential.

We don't "frown upon" those asking for help. We try and help them as best we can by providing the "tools" and how to use them. If 3D printer users just want to just drive from A to B, no one is stopping them from taking their 3D printer to a printer repair shop or having a printer repair person make a housecall when it misbehaves.

Of course, they could have a $35 controller connected to a sub $200 3D printer and the first service call will probably cost that much. Perhaps the A to B "daily drivers" should instead consider both the $35 controller and the $200 printer as commodity parts and just throw them away and buy new when they misbehave.

1 Like

I now feel judged haha. My point is that when a person who says up front that he is not a 'techie' is told to get Putty and ssh into the pi or questioned why he can't spend $8 on a new sd card, it comes across as arrogant and quite unhelpful. Your explanation however was much more helpful as I mentioned above and I certainly do understand the difficulties having myself tried to explain the difference between a backslash and forward slash back in the MSDOS days.

1 Like

I have to jump in here and say this, it's not being arrogant it's the truth, we can assist with troubleshooting however if someone wishes to purchase a raspberry pi and install octoprint on there you do have to learn Linux plain and simple. We can assist but we cannot write a handbook how to use Linux. The user also needs to want to learn.

Also if a user has no SSH experience, it's not a good idea to give someone instructions. Once they gain access and learn the sudo command they can destroy a system very easily. So I think the user should really learn the Linux basics before gaining SSH access.