Octopi on Raspberry 5

Hi,

I have bought my first Raspberry (Raspberry 5 8 GB) and want to use Octopi to control my Ender 3V2.

I downloaded Raspberry Pi Imager 1.8.3. If I select the Raspberry Pi 5 Octopi is not shown in the list of available systems.

If I select Raspberry Pi 4 I can install it. When I want to run it though a message tells me hat my hardware is not compatible and that I shoud change the config.txt to contain "check_os=0" (something like that, sorry, I probably have not memorized it correctly).

Anyway I did this and then upon boot the screen remains black, no more response.

Can you please give me a hint how to get the Octopi up and running on my raspberry Pi 5?

Thanks and regards,
Jens

OctoPi does not currently support the Raspberry Pi 5. Newer OS/firmware is needed for this - that's why it's not showing and says it's not compatible :wink:

Above thread has some links to some (maybe) working nightly builds.

If you want a guaranteed way to install, I would recommend using normal Raspberry Pi OS, and then installing OctoPrint through octoprint_deploy - details on OctoPrint.org - Download & Setup OctoPrint.

Thanks a lot. I tried it and installed it on my Raspberry Pi OS and it works great!

Hi all.

I received a raspberry pi 5 and was able to get pctoprint running on it, but does anyone know how to get the camera working in octoprint? I have the raspberry pi camera module 3. If im on the device I can bring the camera up by libcamera-hello after doing all the updates but when i connect to octoprint on web browser from another pc i cant get the camera to work at all. Even if i ssh into the terminal and do the same command libcamera-hello all it does is run through a few lines, going back through the libes i see the streamer or preview isn't working... Anyone know of a workaround to get the camera working? I also have a ps3eye camera that is pucked up on USB but not displaying like the module 3 camera. I dontind doing a full flash and wiping it again. Anything to get the cameras working

Support for the Raspberry Pi Camera v3 is still in its infancy and is only supported by libcamera. OctoPrint does not interface directly with libcamera but instead requires additional streamer software. The only streamer software that I am aware of that works is camera-streamer and the OctoPrint support for that is currently only available on an alternate build of OctoPi 1.0.0 which is based on Bullseye, not Bookworm so the RPi 5 doesn't work. While there is a nightly build of OctoPi I don't believe it includes the alternate camera-streamer stack.

I'm sure the powers that be are working diligently to get all the pieces in place for the RPi 5 and the camera V3 but it will be a while yet.

Thank you for the response.
So currently no way of getting it to work... Got it.
Any chance of the ps3eye camera working through usb or is it in the same boat as the csi cameras?

There is not 'no way' of getting it to work - you would just have to install camera-streamer yourself. Install Raspberry Pi OS, install OctoPrint on it, install camera-streamer on it. The only thing there isn't is a pre-built OS image with everything packaged up already.

I have octoprint installed by using octoprint_deploy. The only thing I can't figure out is how to install camera-streamer. I have the raspicam v3. I've gone on to the github but can't figure out how to install

Go to https://github.com/ayufan/camera-streamer/releases. On that page you will find instructions on how to install and the assets needed.

Thank you. I tried to go through it but couldnt get it right. I muat ve dping something wrong as the stream on octoprint is still not sgowing any feed. I tried both the package install as well as the manual. I am new at this so most likely not doing something correctly. So frustrating as i cant go back to my old pi 3 as i gave it away. Ims ure the teams are pushing but i really just want to get it working by any means necessary. I hace two more printers arriving at the end of February and was hoping to have everything running smoothly.

I tried as well on my RPi 4B and RPi Camera 3 but couldn't get it right either. I think it's going to take someone cleverer than you or I to figure this out.

Not a problem. Thank you for giving it a shot. Will just have to wait patiently until an official release or a solid workaround... Thanks again. Chris Riley from Chris' Basement YTube had a live session yesterday and said he'd alsi be looking unto it, still needs to get his hands on a device though. List pricing for the pi 5 at a nationwide store mentioned in the video

I was able to get Octoprint itself running on my RPi5 without much difficulty.
My challenge has been with the camera.
I (manually) installed camera-streamer but was not able to get it to work... and according to Raspberry Pi 5 does not appear to be supported at the moment? · Issue #130 · ayufan/camera-streamer · GitHub, it seems that due to the lack of hardware encoding, the RPi5 + RPi camera is not currently supported.

Would love to be proven wrong of course...