Octopi - Problem updating behind a proxy


#1

Hi and thanks for having me.
I have the situation that my internet access is through a corporate firewall and proxy, where i can't do any changes. While i can add the correct http, https and ftp proxy from the raspbian commandline and seemingly at least ping is working i am unable to get any update connection or install any packages.
Any ideas?
Thx in advance


#2

I have the same problem. It was possible to connect raspberries to the Internet, but the octoprint itself does not connect. I can conclude that the Octoprint server works in a virtual Python environment, which needs to specify its proxy settings. How to do it yet I do not know. Knowledgeable people, please help.


#3

I don't have a proxy I could test this with so it would be impossible for me to try this myself.

# Add a line to your ~/.bashrc to set an environment variable
# You would need to adjust that "web-proxy.mydomain.com" to whatever
# your proxy's hostname or IP address is.
echo 'export https_proxy ="https://web-proxy.mydomain.com"' >> ~/.bashrc

Reboot the Raspberry and try it again.

The approach is to set an environment variable which pip should then see and use later when upgrade commands are trying to happen.


#4

It looks like there is a solution, but I can only check it tomorrow. Read here.


#5