Octopi suddenly doesn't show up, not even when plugged directly into router

I've had the same octopi set-up for several months now, today all of a sudden octopi has stopped showing up even in the router interface and while connected through LAN (it usually connects on 2.4g wifi). I've been clicking 'later' on all the updates in the octoprint page and I think the issue may stem from not updating? But then again its been fine for quite a while, so why now?

What did you already try to solve it?
Thinking that the issue was likely a network issue, I disconnected and reconnected the raspberry pi and printer multiple times to no avail. Then I tried connecting directly to the router but octopi still won't show up in the router interface (previously it would).
I have reached the conclusion that the issue is something to do with my octopi installation as neither the wifi nor ethernet cable worked.

Logs (octoprint.log, serial.log or output on terminal tab, browser error console ...)
I'm not sure how I can get logs because octoprint won't work but I have taken a full backup of the sd card (including the EXT4 linux partition).

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ...)
Printer: Anet A8
Browser: Tried both firefox and edge
Raspberry pi 3 Model B V1.2
Octopi version - not the latest one (how can I check?)

Can you connect a display to the pi and see if it's even booting?

If not - what are the leds doing when you turn the pi on?

The power light (PWR) is the only light on. Oddly enough even when the network cable is attached no other lights are on. Unfortunately I do not have a pi display but I tried connecting it to a display (HDMI port) but there's no signal.

Looking online, most sites seem to blame the lack of the other status LEDs on the SD card. Is reinstalling octopi the only solution at this point?

Do you frequently power down the Pi and if yes, how? Just pulling the plug?

It's possible that the networking has gone to sleep (to save power) and behave like this. It's possible to use a tool like uhubctl to turn off power to the first USB hub which includes power to the networking components (oddly enough).

It's possible that if it's grossly underpowered then it might turn off networking.

If it were me, I'd connect a display/keyboard/mouse to it, boot it up and log in locally. I'd then run an ifconfig to see what's going on with the networking devices.

1 Like

Yes, by just pulling the plug on the pi. I didn't think it would cause much harm, does the "
sudo shutdown -h now" command work in the octopi terminal? (found it on some stack exchange thread)

I doubt it was under powered as I connected it to the usb port on my computer as well as its usual adapter and neither made a difference.

Sorry if this is a very rudimentary question but with the other tools you mentioned how can I run them? From what I've read it seems that I need a Raspian image on the sd card to connect to the pi, unfortunately I only have access to the one 8gb SD card so should I install raspian on that or is there an alternative?

Also just to clarify, would you say its more likely an issue with the pi or the SD card?

Yes, by just plugging off the power, there is a great chance to destroy something on the SD card.
And yes, you can use sudo shutdown -h now with the terminal and also via SSH


In addition to @Ewald_Ikemann post - you can also shut it down via the webinterface :slight_smile:

Back too your problem. If I were you I would flash a new octopi image on the sd card and start fresh.
Lets hope your sd card isn't damaged and everything runs fine afterwards :slight_smile:


Sure will do, is there any way to keep the settings? I have the files from the sd card on my pc.

Oh yikes, I'll definitely try to shut it down through the terminal from now on. While we're on the topic, are there any other procedures I should be doing for turning on or off? Like is it ok to just pull the plug on the printer? because I haven't seen any turn off settings on it.

Well yes. The easiest way would be to back them up when the pi is booted but of course that doesn't work.

If you're a windows user I guess the easiest way for you would be to get a linux live image (ubuntou for example), put it on a usb stick, boot it and mount the sd card. Now you backup all files you want.
If you got a second pi you could also connect a card reader to it and mount the card there and back your files up.
I don't have any experience with mac so I don't know if you can mount your sd card without doing anything. I guess the linux live image should also work on a mac.

I have backed up the files using a program which can read the EXT4 partition, how would I go about restoring the settings to the new installation?

Just thinking that if I restore everything, whatever was causing the problem on the current installation would return :sweat_smile:

There's a lot of files here and the config alone doesn't seem to have all the settings.


That's great!
If you didn't change it everything you need should be located in /home/pi/.octoprint

And as I said you don't need to shut it down via terminal - the webinterface does the same if you click on shutdown system :slight_smile:

btw which program are you using?

1 Like

Thanks I'll go ahead and reinstall now. I went through a couple for the program but in the end the one that worked for me was LinuxReader

Thanks to everyone who posted here, I've learnt quite a bit about octoprint in the process.