πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

OctoPi WiFi/network connection troubleshooting megatopic

I can't even get that far. The Putty session won't even open. I punch in the IP that my Pi running octoprint is on and hit "Open" and am immediately given that warning in a typical windows warning box. There's nowhere I could indicate a username anywhere. It's like Octoprint is rejecting my putty connection outright.

Since this is Windows you might now visit the Firewall application and permission port 22 (ssh, PuTTy).

Problem: My octopi is connected to my router and has internet. It shows up on the router list, but I cannot connect to its ip using either a browser or Putty (SSH).

It's supposed ip is 192.168.0.x which is what is expected because my default gateway is 192.168.178.1.
If I run 'ping google.com' using a keyboard and a monitor on the pi, it works. So the pi has internet through the wifi dongle.

Installation
I used rufus to write the 1.3.10 octoprint to my Micro-SD card and it's running successfully on my Raspberry Pi 2 B v1.1

I tried:

  • switching from my extra router to my modem SSID and both give internet, but none allow me to connect through my browser
  • apt-get update and apt-get upgrade
  • scanning wlan0 - it shows my routers properly
  • I rebooted after each change
  • I changed the power supply as it was indeed undervolted

Thanks in advance!

What do you mean by connect to its IP in a browser? By default, octoprint runs on port 5000 so if your trying to access octoprint need to place :5000 on the end of the IP in a browser. Regarding SHH is it definitely enabled on the pi?

1 Like

I 'sudo nano'ed a file with the text 'lel' and name 'ssh' in /boot - and rebooted, but I can still not connect through Putty using port 22 with the ip that is printed out in the pi terminal.

I wasn't aware I had to use port 5000 for browsing on the pi, but even with that, I can still not connect

For the record, on OctoPi you don't have to since it ships with a reverse proxy that makes everything accessible under the stock port 80 (and in fact port 5000 won't work at all on OctoPi unless connecting directly from the Pi).

What's the IP printed in the terminal?

1 Like

192.168.0.197 is the ip

What's the IP of the computer you are trying to access that from? Because based on what you said above it sounds more like your regular LAN is on 192.168.178.0/24 and if your Pi is now on 192.168.1.0/24 for some reason and there's no gateway defined between the two, no wonder you are not reaching it.

1 Like

I wonder if this is one of those times when either the workstation or the Pi has connected to the Guest network on the router (which won't allow full connectivity).

@foosel @OutsourcedGuru I just realised my pc is on a switch. How would I route my pc to the pi that is connected to the wifi on the router.

The connection is as follows.

The switch is connected to the modem-router with a cable.
The pi is connected to the modem-router with wifi.
The pc is connected to the switch with a cable.

You didn't answer the question "What's the IP of the computer you are trying to access that from?".

Without that answer, I'm just guessing that you need to configure the router. They usually have a web interface with a default username and password which is either printed on the outside or in the user's manual. If you don't have a user's manual, try googling for your router's make, model, and "default password". If your modem-router is rented from your ISP, call their support and let them help you get it setup correctly.

1 Like

Why not connect the Pi using Ethernet to your router and call it a day?

2 Likes

192.168.178.16 is the ip of my pc

I have no cables left and certainly wont like to have one from my router, through the living room, up the stairs, through a door, across the room.

1 Like

Then I am no longer guessing, you need to reconfigure your router.

1 Like

You're left with a couple of options: put the PC on the same wifi network or adjust the router so that traffic from one zone can reach the other. And either of those are pretty much outside of the scope of what we can help you with here, to be honest.

2 Likes

Would an option be that I portforward and just use my public ip?

[edt] No I cannot portforward as the pi ip is 'invalid'

I used to do network configurations for a living (I'm retired now) and I find it very strange that a modem-router that has both wired and wireless connections cannot be configured (in fact, didn't come with the default configuration) to allow wired and wireless devices to be on the same network.

What brand (make and model) modem-router do you have? Do you own it or is it rented from your ISP? Does the wireless portion of this modem-router broadcast multiple SSIDs? @OutsourcedGuru asked if it was possible that the SSID your RPi is connected to is a "guest" SSID. You never answered that question.

If this funky modem-router can't be configured with a "sane" configuration, then I would purchase a wireless router of my own, configure it as an access point, and plug it into the switch that the desktop is on. Connect the RPi to that one and it will all just work.

2 Likes

I have a rented Cisco EPC3928AD. The modem-router can broadcast both 2.4 and 5GHz with seperate SSID's but I have them on the same SSID.
I don't know what a 'guest' SSID is, but the pi is on the only SSID that the wifi-modem is broadcasting.

I suppose I could move the second router I have to the switch. I assume that would fix the issue.

Thanks!

Why is it so hard to get any information from you? It is as if you really don't want us to solve the problem you are having.

What is this "second router"? What is it connected to? What is connected to it? There is a good chance that this is the source of your problem.

Since we finally know that you are renting your modem-router, for the last time I will recommend you call your ISP and tell them you want your Cisco modem-router WiFi and wired connections on the same network.

1 Like