OctoPi WiFi/network connection troubleshooting megatopic



OMG!! just got it working using these instructions https://learn.adafruit.com/adafruits-raspberry-pi-lesson-3-network-setup/setting-up-wifi-with-occidentalis

using the wifi adapter i haven't tried the internal wifi yet

EDIT: the internal wifi module is also working


It's an amazing collection of software that works within moments if installed correctly.

I asked for your octopi-wpa-supplicant.txt file contents but you instead chose to insult the software. Your problem is probably in that file, for what it's worth.


After more than 40 hours of trying to upgrade Pip from version 9.01 to 18.0.1. I gave up and tried again with the Basic File. And after purchasing a Raspberry Pi B + to replace my original Raspberry Pi B unit. I once again began a fruitless endeavour to get Octoprint to work with WIFI. And then once again I ran into a Brick Wall where it would work perfectly while wired up to an Ethernet Cable. It refused to do so through WIFI. It was upon this realization that I attempted to Port everything through Raspian but once again that wouldn't work either as Raspian refused to load OctoPrint because it couldn't connect to the server.

But seeing as you asked for it, here is my octopi-wpa-supplicant.txt file with the Password redacted.


I'm suggesting that is not a valid network address. Try instead.

I'm appreciating that you trying to help but let me correct you.
My local network is sitting on
That means my subnet mask is

So all the IP addresses starting from to are on the same network.
This is a valid network just like

And you completely ignoring the fact when I flush the OS of the raspberry pi to something different like raspbian the WiFi connects without a problem.

The problem is with OctoPi OS itself, most likely with the drivers for the WiFi Chip.
This is why so many people are experiencing the exact same problem.
Due to some raspberry pi boards having different WiFi chips.

Regarding the configuration of my home network I am more than qualified and i know what i'm doing.
All my devises are connecting with no problem including the raspberry pi, just not with OctoPi image.


@NeoLoger I got my start in I.T. seven days after the IBM PC came out. I actually worked on the ARPAnet at the Pentagon before the Internet was available.

As they say, "you can lead a horse to water, but you can't make him drink".


Is your wi-fi zone hidden (no broadcast)? The extra key/value pairs in the network paragraph are in question.

Unfortunately, you haven't indicated what happens after this paragraph. I'd suggest copying/pasting what I have here to replace your entire file contents. It's from my own troubleshooter tool.

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
        scan_ssid=1     # Use this only if your zone is hidden, otherwise omit entire line


I'll give this a shot and let you know. Though after playing around in VirtualBox with the RaspianDesktop2017-11(32Bit).VDI File Image. I did notice that to get the Raspberry Pi 3 B+ to work with WIFI, I had to go into the Preferences Folder and under Networking actually highlight the SSH Icon. The other thing I did happen to notice though is that even after installing OctoPrint in a Raspian Environment. There is no easy way to bring it forth onto the screen of the Raspberry.


@rockman44181000 OctoPrint is a web service, among other things. If you want to see the web interface, you have to visit it with a browser.

Assuming that you have a screen permanently connected to your Raspberry, you could run the sudo ~/scripts/install-desktop script to add the PIXEL/Desktop GUI, install Chromium and then bring up the web interface locally on the Raspberry.


Look I am sorry if i offended you, i just I got really frustrated with this problem.
I was wreaking my brain on this for several days and wasted more than one weekend to figure it out.

My day job is a System Engineer and i spend 10+ hours a day configuring Linux server on the cloud for costumiers and fixing problem, I'm literally breathing Linux, configuring a network interface is one of the most basic thing i do every day.

Any way, apparently there might be something wrong with the WiFi chip of my raspberry/raspberry model
I can see the networks but no matter what i do it wont connect, I tried using external USB network adapters i had laying around and they didn't work ether(maybe Linux compatibility issue i didn't checked).

Eventually I gave up on trying to fix the WiFi that comes builtin and after some research I purchased
A new USB WiFi network adapter TL-WN725N as soon i plugged it to my raspberry it instantly connected to my home network without any additional configurations.

I'm suggesting to consider adding this as a last resort solution to the WiFi problem.
Because i still have no idea why the builtin WiFi chip won't connect as it seems it can detect the router's WiFi signal perfectly.


I get it. You still don't believe me. But I'm right on this account.

The PacBell guy who arrived in my datacenter (as in "I owned and operated my own datacenter") similarly issued me a network range which wasn't kosher. He also gave me the "I'm the expert here" speech. I had to spend a good thirty minutes of my time on the whiteboard teaching him at the binary level how netmasks are applied.

To determine the number of subnets, use the 2x-2, where the x exponent is the number of subnet bits in the mask.

That "-2" part of the equation means that you need to throw away two subnets since they can't be used. This means that is an invalid network. The first valid network is


I've tried that script as well as a few others and I still can't get OctoPrint to appear in the Chromium Web Browser. Even though if I ls -h in the Root Directory I can see OctoPrint and all of its Files. I'm now trying the Budgie Desktop and any others that seem like they might work.

It would be interesting to figure out what was actually changed in the Raspbian Desktop when OctoPrint was Incorporated into it. Unlike the OctoPrint Download 15.01, the Raspbian Download didn't require any effort on myself to modify the octopi-wpa-supplicant.txt file.


@rockman44181000 You might also see if you can go to http://localhost:5000/ from Chromium.


I tried that too and now to top it all off. My Raspberry can't be seen by my network. Wired or Wireless. Go Figure.


I note that I've installed more Raspbian and OctoPi images than I can remember. I wrote a database program and I put tiny labels on the microSD and their respective SD adapters. I'm now up to 164 as an ID tag for the last one I did today.

  • I follow the basic instructions on the OctoPi repository. I always use Etcher. I note that in some cases (like in Windows) it tries to unzip the file it downloaded but this is not preferable, let Etcher have the zip version.
  • My network has both 2.4Ghz and 5Ghz zones (I only have a Raspi3B and Zero's which only support 2.4Ghz). My zone displays on devices like an iPhone wi-fi connect page (it's not hidden).
  • I edit the /boot/octopi-wpa-supplicant.txt in each case.
  • I boot them up and they always connect unless I've made some typo.

And by "they work", I mean that since I do so many of these I have to edit my workstation's ~/.ssh/known_hosts file to remove the last "octopi" or "raspberrypi" entry.

I might put a monitor/keyboard/mouse onto the Raspi to see what happens when it boots. You can then do an ifconfig locally to see if anything binds to either adapter. When you suggest that Ethernet isn't working then you'd need to go this route. It's possible that it's not even booting.

As discussed earlier in this thread, on my router I make sure that I've issued a valid network address like, for example.

Interpret the LEDs on the Raspi and see what it's trying to tell you.


Upon power up my RPI based Octopi works fine and has no WIFI connectivity issues......but after 2-3 days, while it shows in the router as connected, no local host on its subnet can ping it, much less connect....it takes a power cycle on the RPI and its back operational...

its a straightforward classic install of Octopi on the RPI with no deviations or changes....

its almost like its related to the renewal of the router's DHCP lease to the Octopi, although I cant tell what that period is, but its repeatable like clockwork...like it renews but loses IP routing connectivity....no other issues on the network...

any suggestions?


I'm using the Pi Model 3 B, flashed octopi-stretch-lite-0.15.1 to a 32GB microSD with Etcher, can't seem to get it to connect. It gets stuck at line " random: crng init done", not sure if this is supposed to happen...

What I've tried (basically everything from the troubleshoot):

  • flash using Win32DiskImager

  • using a different microSD card

  • using 5V 3A power adapter

  • using Notepad++, also Atom text editor

  • checking router's set-up/control page, Angry IP Scanner

  • connecting Pi through an ethernet cable (with the following octopi-wpa-supplicant.txt, not sure if I'm supposed to comment out the wifi settings when using ethernet?), but still don't see it under "connected devices" on router's set-up/control page.

Other info:
-No, I don't have a hidden SSID.
-Yes, it's on 2.4G, not 5G.
-Yes, I have good Wifi reception and the Wifi module is working. Installed NOOBS previously to confirm. Was able to see it under "connected devices" on router's set-up/control page.
-Yes, I'm Canadian. :slight_smile:

My octopi-wpa-supplicant.txt:

# Use this file to configure your wifi connection(s).
# Just uncomment the lines prefixed with a single # of the configuration
# that matches your wifi setup and fill in SSID and passphrase.
# You can configure multiple wifi connections by adding more 'network'
# blocks.
# See https://linux.die.net/man/5/wpa_supplicant.conf
# (or 'man -s 5 wpa_supplicant.conf') for advanced options going beyond
# the examples provided below (e.g. various WPA Enterprise setups).
# Do not use Wordpad for editing this file, it will mangle it and your
# configuration won't work. Use a proper text editor instead.
# Recommended: Notepad++, VSCode, Atom, SublimeText.
# If you use Textedit to edit this file make sure to use "plain text format"
# and "disable smart quotes" in "Textedit > Preferences", otherwise Textedit
# will use none-compatible characters and your network configuration won't
# work!

## WPA/WPA2 secured

## Open/unsecured
#  ssid="put SSID here"
#  key_mgmt=NONE

## WEP "secured"
## WEP can be cracked within minutes. If your network is still relying on this
## encryption scheme you should seriously consider to update your network ASAP.
#  ssid="put SSID here"
#  key_mgmt=NONE
#  wep_key0="put password here"
#  wep_tx_keyidx=0

# Uncomment the country your Pi is in to activate Wifi in RaspberryPi 3 B+ and above
# For full list see: https://en.wikipedia.org/wiki/ISO_3166-1_alpha-2
#country=GB # United Kingdom
country=CA # Canada
#country=DE # Germany
#country=FR # France
#country=US # United States

### You should not have to change the lines below #####################

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev

Photo of when it boots (with only HDMI connected, no ethernet or anything):

It's my first time using Raspberry Pi, a complete newbie. I might be missing something obvious, please have patience.


The default DHCP lease is often a day. Feel free to go into your network router and adjust this to three weeks.

Also, you didn't mention which workstation operating system you're using (Windows, OSX, Linux). OctoPi broadcasts its hostname best on Bonjour, for what it's worth. So if you installed that service on Windows it might behave better.


Try following these step-by-step instructions. Follow them exactly as written.


Its windows8.1....It's not a hostname issue...I try to ping directly with its ip address....shows leased and connected on the wifi subnet with that ip in the router, but wont answer ping or broadcast ping (arp -a) after a few days....am now going to have it crontab reboot every night at midnight and see if the problem disappears since rebooting it allows it to communicate again on the subnet...this happens on RPIOW and RPI3b+ that I have using the standard Octopi image installed per instructions...


I followed these.. OctoPrint.org - Download & Setup OctoPrint .dont see any significant differences in the install instructions...