OctoPi WiFi/network connection troubleshooting megatopic

troubleshooting
wifi

#162

OH MY GOD! THANK YOU! THAT FIXED IT!!! I thought I'd have to wait days for a response ;-;;

Couple things the guide did differently (For those who run into this same problem in the future @hwurzburg ):

  • Download directly using "curl" through command prompt.

  • Install Bonjour.

  • Burn the .zip file directly, not the .img file inside. (This is actually a lot faster too!)

  • include "key_mgmt=WPA-PSK" in the octopi-wpa-supplicant.txt (I don't think this is what fixed it, but hey it's working :smiley:)


#163

@xKen The new problem is that some of these browsers or operating systems want to try to help you by automatically unzipping the download and end up tweaking something.

@foosel, @guysoft


#164

Windows is affected by not only the DHCP server's lease (if it's trying to find octopi.local) but it's also affected by its own arp cache, for what it's worth. The arp cache empties out after some amount of time which nobody knows other than the geek who wrote that document.

Somehow this feels more like a router-based problem than it does your Raspberry. If it were me, I'd wait until the problem shows up again (having put a keyboard/monitor/mouse on the Raspberry) and then run an ifconfig locally on the Pi to see if the wlan0 has its RUNNING flag.


#165

Greetings,

I am having an interesting problem with getting OctoPi to work with my Raspberry Pi 3. Before, I followed the exact steps of everything (flashing to a freshly wiped microSD card, editing the wpa file properly with Notepad++, putting in microSD card before using a wall outlet power supply to turn it on) and it worked instantly at school. However, now that I am home the octoprint is not showing up at all. I have changed the

  1. Changed the wpa text using Notepad++
  2. Wiped the microsd card and reflashed it
  3. Confirmed with my home internet that octoprint was indeed connected (still got nothing from the octoprint.local)
  4. Used a different microsd card
  5. Used an entirely different router that I had used and worked at school (still no good)
  6. Plugging in an HDMI does nothing (I assumed it was suppose to let me edit it/check that it works) so I don't think I can get diagnostic info atm...
  7. There is a solid red LED. A green led flashes every now and then (no pattern it seems)

So its my understanding that the raspberry pi is working and connected, but I can't access it from the outside. Very sad/annoyed because it was perfect the first time but now not working at all :confused: anyone have advice?


#166

Been struggling to get my pi 3 to connect through wifi, made changes to wpa_supplicant.conf as instructions said and didnt get it to work. got it working with some interface changes, but suddenly stopped working.
Decided to start over, and thist time didnt change anything in wpa_supplicant.conf, i just used raspi-config to change localisation settings, and then it allowed me to change wifi settings and wifi started working instantly.


#167

Rewind this thread to this post and try those instructions.


#168

Nightly rebooting did not resolve the issue...it still happened sporadically...finally, resolved..... it was indeed a router issue....I was also having issues keeping my printer on-network....I replaced the wireless router with another one and haven't had an issue since....as a bonus, I increased my traffic speeds by 4x to the internet on 5G with the same host adapters....the Spectrum cable modem/router's 5G wireless/routing apparently was the issue...no problems for several days now since I replaced the router function with a new one....my wifi printer doesnt become un-reacheable either...


#169

Hi,

I've been having difficulty getting octoprint to work via wifi. I have octopi installed on my rapsberry pi 3b+ and it works when I connect to the IP address when the pi is connected to the network via ethernet. I then SSH into the pi and enter the ifconfig command and it shows the following:

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.238 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 2a01:4c8:143c:aad1:6026:80b3:3a2a:2a14 prefixlen 64 scopeid 0x0
inet6 fe80::ca6b:aec0:e419:da45 prefixlen 64 scopeid 0x20
ether b8:27:eb:48:91:e6 txqueuelen 1000 (Ethernet)
RX packets 373 bytes 80161 (78.2 KiB)
RX errors 0 dropped 1 overruns 0 frame 0
TX packets 255 bytes 44048 (43.0 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536
inet 127.0.0.1 netmask 255.0.0.0
inet6 ::1 prefixlen 128 scopeid 0x10
loop txqueuelen 1000 (Local Loopback)
RX packets 74 bytes 18380 (17.9 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 74 bytes 18380 (17.9 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST> mtu 1500
inet 192.168.1.115 netmask 255.255.255.0 broadcast 192.168.1.255
inet6 2a01:4c8:143c:aad1:3063:6e05:3a0c:3844 prefixlen 64 scopeid 0x0
inet6 fe80::7865:ab73:7274:3805 prefixlen 64 scopeid 0x20
ether b8:27:eb:1d:c4:b3 txqueuelen 1000 (Ethernet)
RX packets 66 bytes 9481 (9.2 KiB)
RX errors 0 dropped 0 overruns 0 frame 0
TX packets 120 bytes 31467 (30.7 KiB)
TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0

This suggests that the wifi connection is working as it states running next to the section marked with wlan0. However, when I unplug the ethernet cable and go to the wifi IP address of 192.168.1.115 the browser wont connect. It is also goes from being discoverable on angryIP scanner when connected via ethernet, to disappearing when the ethernet cable is removed.

Any help on this is much appreciated.


#170

Both your wifi zone and your Ethernet network have the same IP network assigned (192.168.1.0/24) for what it's worth. I'm not sure if your wifi router is in bridge mode or what. What's challenging for you on your workstation is that you should only have one device with a default gateway assigned (don't include a default gateway for both Ethernet and wifi adapters, in other words).

Can your Ethernet-connected (only) workstation reach anything else that's attached to the wifi network or does it similarly fail? The problem could be your router itself.

On my own workstation (macOS), I can run something like route get 192.168.1.0 and it would give me a report of how my packets would try to get there. I can also do a netstat -nr and it will show me the routing tables that it's built. You'd be interested in both the default route (making sure that when your Ethernet cable is disconnected it's now the IP address of your wifi adapter). You're also interested in the 192.168.1/24 route. A reference to link#6, for example, here would mean "the sixth device as seen in an ifconfig report`.


#171

Hello everyone , i'm having some network issues

I instaled octopi into my raspberry, it was working fine but suddently my network fell and neither the pi nor the phones or the computer internet worked anymore

The inner network is working properly

By the way, i have two routers and THE ONLY COMPUTERS AND PHONES wich lost the internet are the ones connected to the same wifi that the pi has.

When i shutdown the pi, the network restores itself and it works fine

And the problem is intermitent, sometimes everything works fine then crashes, 5 minutes works again and then 10 minutes later crashes again......

I'm becoming a little bit desperate, so please, i'm begging you, someone has any idea of what the heck is going on?

PS: is my first pi and my first printer, and i'm not the brightest person with networks, so, small word please :wink:


#172

Hi there everyone,

I am having an interesting issue here.

I am running octoprint in rapberry pi 3 model B and is working perfectly, not any issues whatsoever. Now, I am trying a little upgrade of my raspberry pi to a model 3 B+, just switching the SD card from one to another.

We connect the device vĂ­a ethernet and whereas in the raspberry pi 3 model B I was not having any connection troubles, I do not manage to make the connection work in the new raspberry pi 3 model B+ . When I connect the ethernet cable in the model B ans switch it on, the LEDs below the ethernet plug start blinking giving the feedback that the connection is OK. Well, I do not have that feedback when using the model B+.

I've checked the files in te SD and all seem fine.

Any idea why this could happen besides the fact that maybe (just maybe) the ethernet port in the new board could be damaged?

Thanks in advance!


#173

How long ago did you start with the non-plus 3? It could be that the sd card contains a kernel that doesn't support the 3+. In that case, you would have to put the card back into the non-plus, ssh into it and run sudo apt-get update && sudo apt-get upgrade. Once that has completed, you should be able to use the SD card in your 3+. Note that the 3+ needs a beefier power supply than the 3 though.


#174

I think I started using it around 4-5 months ago.
I will try to do what you suggest and come back with the result.

Thank you!


#175

Hi, I have two wifi networks in my home, one has gateway 192.168.0.1 and other 192.168.1.1.

When I first setup the octopi, I used the wifi network that had x.x.1.1 gateway. Later I needed to change connection to network with x.x.0.1 gateway.

When I'm connected to x.x.0.1 I can remotely connect to octoprint, stream camera, all works, however octoprint reports it is not connected to internet so it cannot download announcements, etc. Even when there is a newer version available it reports that all software is up to date.

When I'm connected to x.x.1.1 all works, no issues.

This is an issue that is ongoing since day one, maybe 1.5 years... Everytime I update to a new version I'm hoping it will get fixed but still have not. Currently running "OctoPrint 1.3.8 running on OctoPi 0.15.1".

I'm not even sure if this is an octopi issue, so I thought I ask the question...

Thanks...


#176

Hi everyone!

I'm running a Pi 3B+, OctoPi 0.16.0 0.15.1.

I have setup, connected, and successfully printed multiple times and everything works great.

The issue:
Unfortunately there's times where the OctoPi decides it wants to quit. This means I can't connect to the IP on the browser UI or in Putty. However, it doesn't look like Octoprint stops because it doesn't interfere with the current print running, I just have no way to connect until the print finishes and I hard reset the Raspberry.

I am new to OctoPrint - and new to raspberry, which means what I know how to fix or provide is limited. But I will be glad to provide anything requested, and walk through any other questions you have in what I'm running/how.

Thanks!


#177

@koksala This almost sounds like the 192.168.1.x network is a guest network and doesn't include broadcast traffic like Bonjour. And in some cases, it won't allow traffic from the guest network to enter the private network (only the public network).


#178

@MaplePrints It could be simply a routing issue, or a short-duration DHCP lease timing out from your router. Try to ping octopi.local. If that succeeds, then your arp cache might be able to figure things out.


#179

Issue is with the 192.168.0.x network, and I'm sure it is not a guest network; that function of the router is turned off.


#180

I need help: I'm using OptoPI 0.13 and I can't change to a new network. Optoprint has been working rocksolid for the last few year, but now that I changed my router name (moved out), I can't change the sign in info, despite editing octopi-network.txt.

As a trouble-shooting measure I change the name of my new router to the old name of my previous networks and works fine. Is as if it ignores the octopi-network.txt. Is there another file I may need to change?


#181

Hey bud, thanks for the reply.

I ran a ping at the result was "Destination Host Unavailable".