🇺🇦 We stand with Ukraine! 🇺🇦

Octoprint 1.3.11

What is the problem?

What did you already try to solve it?

Logs (octoprint.log, serial.log or output on terminal tab, ...)

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, ...)

I use my pi to run my 3d printers. All have been working great. I turned one on the other day and it wanted to update to 1.3.11 so I clicked ok. That was a mistake. Now it does not work correctly. I tried to print a file and it said too big for print volume, I already printed it on the same printer before the update and it worked great. I tried to flash firmware which I have done many times and it failed. It just does not work. I am not a coder but I want to put this back to 1.3.10 and I have searched online for help and most what I find is very complicated. Is there a easy way or at least could someone walk me through it. I have 5 other pi's running octoprint and I thought they were are all still 1.3.10 I did not update them but I see they are all 1.3.11. Have not used them for some time so I am not sure how they work but I know the one that I just updated (I clicked to update) is not working.
Octopi ver 0.15.1
Can anyone help with this? Just a note I have not tried to flash any of the other printers lately so I do not know if it would work since they are all 1.3.11

Go into the octoprint settings and check your printers profile and bed size. I guess it's off or the wrong printer profile is selected.


I checked that first and its correct. Any other ideas?

Are all the printers the same make and model? Are all the Raspberry Pi's the same make and model? If so, then you could copy the SD card on the RPi connected to a working printer and use it on the one that doesn't work. If you don't have a identical working configuration, then I guess you need to restore the system from a previous (working) backup.

OctoPrint does not update itself automagically, it only tells you that the update is available. You will have to figure out what gremlin updated the 5 other systems on your own. If you wish to restore one (or more) of your printers to 1.3.10, then the following is the best help available.

If you actually want help troubleshooting the problem configuration, then please provide details and logs for that configuration.

I guess my mind is almost gone.I will admit I have been ill lately(really) thats why the printers have been idle. Even if they are all updated with the latest Octoprint I would not have tried a firmware flash since they updated. I recently got the Ender 5's and I am doing upgrades to them. Thats why the need to flash them.
I have 14 printers I have pairs of most. I do have another Ender 5. The Pi's are all the same with the same OS. I hate to try flashing any printer just to test a Pi. Anything could happen and I do not want to change any more mainboards. I did just replace both these Ender 5 boards as an update to TMC 2208 drivers.
I am stupid when it comes to code. I get by with youtube and forums as far as that goes. I am very good with machines so thats half the battle. When I was an Aerospace Machinist there were no computers so never learned machine code. Wish I had but cant make myself young again.
The closest we had to CNC or automation were multi spindle chuckers.
I think we got 2 tape punch machines in as experimental right before I left. Tells you how old I am.
So you say I can just copy the sd card? Any special method needed?
I did find that info for restoring but I got lost reading it. Just so much I have never done or heard of. Heck I was afraid of the Pi's when I first got them because of the procedure for getting them ready for printing. I watched a youtube video and was able to get them all done. I just bought another 6 months ago and I had to go back and watch the video again because I forgot much of the procedure.
Let me know about how to copy if theres a special method. I will try that. If copying does not do it I would appreciate any help you can give trying to figure the issue.
I will do what it takes to troubleshoot as long as you let me know what I need to do.
Thanks so much

Since I'm on macOS (Apple) I'm rather fond of ApplePi-Baker as a method of backing up the entire microSD image and then cloning it or even restoring it back over the original microSD card. If you have 14 printers/Raspberry Pi computers, you should have 14 files on your computer somewhere with a backup representing each one. Since that software can save to ZIP format, the IMG is probably 2GB for each so you'd be looking at about 30GB to store one recent backup per printer. I would suggest a filenaming standard that allows you to quickly get to the correct one.

You can even clone a microSD from a working printer like this and then edit the resulting new microSD card. Once it's cloned, leave that original/working printer offline while you bring up the cloned card in the problematic printer. Remote into that one, run sudo raspi-config and immediately change its hostname to avoid problems.

If you do clone a card like this from another working printer, you should also visit that printer's /home/pi/.octoprint/config.yaml file and manually edit it using nano. Wherever you see DELETETHISBIGVARIABLE below, delete that part. Save the file and restart OctoPrint and it will create new variables which are unique to this printer.

api:
  allowCrossOrigin: true
  key: DELETETHISBIGVARIABLE
...
  discovery:
    publicPort: 80
    upnpUuid: DELETETHISBIGVARIABLE
...
  tracking:
    enabled: true
    unique_id: DELETETHISBIGVARIABLE
server:
  secretKey: DELETETHISBIGVARIABLE

Unfortunately I never backed them up. So unless they do it auto they are not done. I looked on the one that will not work correctly for a backup and there was none.
I will follow your directions to copy it. What is nano? never heard of it. Like I said I am dumb when it comes to software coding. I would never touch it before for fear of screwing stuff up. you cant know how long I went not touching firmware for fear of bricking a board. I did that with a $1000 smart phone. I wanted to get root access so I could use backup apps that backed everything up. I tried on a brand new phone and bricked it.
Never said I was smart because when I got another new phone I was able to root it. Sometimes my stubbornness gets the best of me.
I will try this tomorrow and post back what happens and if I need any further help.
Till tomorrow
Thanks

Great I cloned the other Ender 5 I have and changed the name on the other Ender when cloned. It worked! I guess it must have been corrupted. Now I know how to clone so I will be ok for next time.
Thanks a bunch for your help.

Thanks to the help here I cloned the sd card and its fixed. I did learn one lesson and that is backup all the Pi's. I am in the process of that right now. Thanks for your info I will print these posts so I have the info next time. I am guessing corrupt files. I have lost power in the past and the Pi's shut off without shutting them down the right way. Maybe this is a factor. I now however run all my printers and Pi's to UPS for the quick power outs we get here in Florida. I know they wont run them for a long time outage but for the 30 sec. brown outs we get all the time it keeps the printers and Pi's powered up with no loss.

Thanks again

Yeah, absolutely. Those brown-outs can eventually end up with a perfect timing where it was attempting to write to the microSD and gets corrupted.

For anyone else reading along, I sometimes use ApplePi-Baker to backup to an ISO image and then simply use Etcher to flash it to another microSD.