Octoprint 1.7.2 won´t detect Prusa MK3S+ after Firmware-Update to 3.10.1

What is the problem?

Before I made the firmware update from official 3.10.0 to official 3.10.1 at my Original Prusa MK3S+ everything works like a charm. No problems with Octoprint transmitted print jobs, never loose of serial communications, nor any other issue. It simply workds for weeks (and more) flawless.

After the firmware update (using official Prusa tools, firmware update was successful) I can´t access the printer using Octoprint anymore. Error message: "Status: Offline after error. No more candidates to test, and no working port/baudrate combination detected."

What did you already try to solve it?

Perform a factory reset of the Prusa MK3S+ - no sucess.
Disable Octoprint´s automatic firmware detection and try some settings - no success.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No. Same problem.

Systeminfo Bundle


Additional information about your setup

OctoPrint version: 1.7.2
OctoPi version: 0.18
printer: Original Prusa MK3S+
firmware: 3.10.1
browser: FireFox 64 Bit 95.0.2
operating system: Windows 10 64-bit Professional

Octoprint running on Raspberry Pi 3B+ connected using DHCP and LAN to local network

All was running perfect until I perform the Prusa firmware update. Nothing else changed, no cable, no software - nothing :slight_smile:

Thanks for any help!

Have you checked for this setting?

The setting you mentioned is only needed to set to "ON" if a Raspberry Pi ZERO is directly connected to the Einsy-Mainboard of the printer. I have a standard RPI 3B+ connected using USB to the printer.

I know, but maybe since the firmware update it might have changed it's setting

same prob here, my solution is, set the Port and Baudrate to AUTO and then try to connect. works here

This was one of the first things I´ve tried :slight_smile:

Problem solved - Although I think it´s a strange behaviour. I switched the language of the printer to English, repeat detection and it works.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.