Octoprint boot stuck in loading webcam daemon

What is the problem?

On fresh install the octoprint boot is stuck in trying to load the webcam daemon (which I dont wish to install).
It continuesly prints the following lines:

Started the OctoPi webcam daemon with the user specified...
Stopped the OctoPi webcam daemon with the user specified...

What did you already try to solve it?

Google for others with similar problems, but only solution that I found requires a working console.

Have you tried running in safe mode?

No, I have no access to console since the boot wont finish

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

Ocotprint 1.18.0

Hello @octo_smurf !

What happens when you pull out the cam (if it already plugged in)?

Thank you for your reply!

I dont have a cam.

So what's the use of the webcam daemon?

Probably none, I would disable it if I could use the console, but like I said it gets stuck trying to load the daemon.

Actually found an related issue: OctoPi spamming webcam daemon service starting & stopping messages and here: webcamd service keeps endlessly restarting every second if there's no compatible camera attached · Issue #740 · guysoft/OctoPi · GitHub

It would be nice if it was possible to install a version with Raspberry Pi Imager without that bug.
So currently everyone without camera will be stuck in the boot-loop without beeing able to access the console.

You should be able to find the nightly builds as well in the RPi imager.

I don't think everyone is stuck in a boot loop as we would have had a lot more bug reports/issues. As far as I knew it didn't stop the console from working, it just continually restarts in the background.

Unfortunatly I cant do anything tough :frowning:
but nightly build is a good idea. Thank you.
I discovered that my wlan usb stick isnt working for some reason. Maybe if it would be working the server would be still up and running and most of the people dont realise that the console is blocked. That would explain why there are no or only some complains.

If you hit "enter" you will get the login prompt
Then you have a console
sudo systemctl stop webcamd
sudo systemctl disable webcamd

cant confirm that, hitting enter did not bring the login to the foreground

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.