Octoprint crashes, with no log

What is the problem?

Today i got my OctoPrint back running after about 2 years without maintenance. I updated anything, at the end it was running and i started a print job. For no visible reason the printer got stuck mid printing and Octoprint is unavailable.

I see only:

The OctoPrint server is currently not running

If you just started up your Raspberry Pi, please wait a couple of seconds, then try to refresh this page.

If the issue persists, please log into your Raspberry Pi via SSH and check the following:

  • Verify that the process is running: ps -ef | grep -i octoprint | grep -i python should show a python process:

pi@octopi:~ $ ps -ef | grep -i octoprint | grep -i python
pi 1441 1 6 11:12 ? 00:00:15 /home/pi/oprint/bin/python
/home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000

  • If it isn't, the question is why. Take a look into ~/.octoprint/logs/octoprint.log, there might be an error logged in there that helps to determine what's wrong.
  • You might also want to try if you can restart the server (if no obvious error is visible): sudo service octoprint restart.

If all that doesn't help to trouble shoot the issue, you can seek support on the OctoPrint Mailinglist or in the OctoPrint G+ Community. Please provide your OctoPi and OctoPrint versions, your octoprint.log (in form of a pastebin link) and explain what you already tried and observed as detailed as possible.

What did you already try to solve it?

tryed to restart, checked the logs. Nothing in the logs, not restarting

tryed to install latest updates again:
bash oprint/bin/pip install --upgrade OctoPrint
response:
import: unable to open X server ' @ error/import.c/ImportImageCommand/364. import: unable to open X server ' @ error/import.c/ImportImageCommand/364.
from: can't read /var/mail/pip._internal.cli.main
oprint/bin/pip: line 7: syntax error near unexpected token (' oprint/bin/pip: line 7: sys.argv[0] = re.sub(r'(-script.pyw|.exe)?$', '', sys.argv[0])'

Have you tried running in safe mode?

I added startOnceInSafeMode: true to the server in config.yaml

Did running in safe mode solve the problem?

no

Systeminfo Bundle

Did not find any functioning documentation, how to get this

WRITE HERE

Additional information about your setup

The programs included with the Debian GNU/Linux system are free software;
the exact distribution terms for each program are described in the
individual files in /usr/share/doc/*/copyright.

Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
Last login: Sat Dec 9 17:12:00 2023 from 192.168.123.31
Traceback (most recent call last):
File "", line 1, in
ImportError: No module named octoprint._version


Access OctoPrint from a web browser on your network by navigating to any of:

http://octopi.local
http://192.168.123.46

https is also available, with a self-signed certificate.

This image comes without a desktop environment installed because it's not
required for running OctoPrint. If you want a desktop environment you can
install it via

sudo /home/pi/scripts/install-desktop

OctoPrint version : unknown
OctoPi version : 0.14.0

this is probably the main reason why. it would be way easier for you to just start from scratch and flash a new sd card with the latest version.

I'll give it a try... but as it was running, the ui stated that its the latest version, all updates installed

If you didn't upgrade the installation to Python 3 you won't get any updates anymore.

It's really the best to just upgrade everything

Just click on the blue link next time :wink:

So this just happened to me yesterday as well. I was running Octopi 1.0 though. Pretty sure I was was running the latest version of OctoPrint as well (there weren't any available updates). I couldn't even find the logs at all, it was like the OctoPrint install was just gone, but I'm also not that knowledgeable with Linux.

The day prior I had ran sudo apt full-upgrade and sudo apt upgrade because I haven't updated anything on the OS side in a while and I was having issues with my OctoPrint instance.

May I ask what plug-ins you were running? I had been adding/removing some plug-ins before all of this happened, so I'm wondering if it was one of those that caused instability.

What does that mean? Folders and files gone?
Did you also get The OctoPrint server is currently not running?

Yes, I got the exact error message stated in the OP. I went to look for logs, but the Octoprint directory seemed to be empty or I wasn't looking in the right spot. The only thing I saw in the Octoprint directory was a Readme file.

the files would typically be in /home/pi/oprint/.

apt full-upgrade performs the same function as apt-get dist-upgrade.

man apt

full-upgrade (apt-get(8)) performs the function of upgrade but will remove currently installed packages if this is needed to upgrade the system as a whole.

man apt-get

dist-upgrade in addition to performing the function of upgrade, also intelligently handles changing dependencies with new versions of packages; apt-get has a "smart" conflict resolution system, and it will attempt to upgrade the most important packages at the expense of less important ones if necessary. The dist-upgrade command may therefore remove some packages. The /etc/apt/sources.list file contains a list of locations from which to retrieve desired package files. See also apt_preferences(5) for a mechanism for overriding the general settings for individual packages.

so by doing full-upgrade instead of the other apt-get dist-upgrade, things may have been removed (ie python version being referenced by the OctoPrint venv).

Yea I figured it was something I did. But everything was running fine. I was doing a 28hr print and Octoprint just crapped itself 23hrs in causing the print to just stop. I did check /home/pi/oprint and that seemed suspiciously empty as well. Time for a fresh install I guess. No big deal other than that long print wasted.