OctoPrint-DisplayPanel not installing

What is the problem?

Unable to install the plugin DisplayPanel.

What did you already try to solve it?

-Installing from plugin manager
-Installing from Git-Hub link
-Disabling all plugins manually and then trying to re-install in case it was a plugin conflict

Have you tried running in safe mode?

No, because it would disable all plugins.

Did running in safe mode solve the problem?

Not applicable.

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


octoprint.log (267.8 KB) plugin_pluginmanager_console.log (75.5 KB) serial.log (148 Bytes)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.5.3, OctoPi 0.18.0, Ender 3v2, Marlin bugfix 2.0.x (from a week ago), Safari, MacOS BigSur

Hello @patofoto !

Not related to your problem, but:

These are quite buggy:

It looks like the name might have changed to 'Micro Panel'. This may mean that you get two installs, and they conflict. You can uninstall the old one by running:
~/oprint/bin/pip uninstall OctoPrint-DisplayPanel

Try this, see if it works.

Will try to reinstall Marlin to the stable release. Thanks.

~/oprint/bin/pip uninstall OctoPrint-DisplayPanel
WARNING: Skipping OctoPrint-DisplayPanel as it is not installed.

Got this warning so I guess it is not installed?.

Yeah, on closer look I found the problem:

2021-02-03 20:18:32,498 - octoprint.plugin.core - ERROR - Error loading plugin display_panel
Traceback (most recent call last):
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/core.py", line 1298, in _import_plugin
    module = _load_module(module_name, spec)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/plugin/core.py", line 69, in _load_module
    return imp.load_module(name, f, filename, details)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/vendor/imp.py", line 238, in load_module
    return load_package(name, filename)
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint/vendor/imp.py", line 212, in load_package
    return _load(spec)
  File "<frozen importlib._bootstrap>", line 696, in _load
  File "<frozen importlib._bootstrap>", line 677, in _load_unlocked
  File "<frozen importlib._bootstrap_external>", line 728, in exec_module
  File "<frozen importlib._bootstrap>", line 219, in _call_with_frames_removed
  File "/home/pi/oprint/lib/python3.7/site-packages/octoprint_display_panel/__init__.py", line 16, in <module>
    from board import SCL, SDA
  File "/home/pi/oprint/lib/python3.7/site-packages/board.py", line 48, in <module>
    from adafruit_blinka.board.raspberrypi.raspi_40pin import *
  File "/home/pi/oprint/lib/python3.7/site-packages/adafruit_blinka/board/raspberrypi/raspi_40pin.py", line 3, in <module>
    from adafruit_blinka.microcontroller.bcm283x import pin
  File "/home/pi/oprint/lib/python3.7/site-packages/adafruit_blinka/microcontroller/bcm283x/pin.py", line 2, in <module>
    import RPi.GPIO as GPIO
ModuleNotFoundError: No module named 'RPi'

It looks like the plugin might be missing a dependency, it is probably a good idea to report this to the plugin author, on Github. In the meantime, ~/oprint/bin/pip install rpi.gpio should install that dependency.

1 Like

I did notice that and installed rip.gpio but maybe in the wrong directory. Will install and try. Thanks.

This worked. The RPi module had not installed in the right directory before when I had tried that. Thank you. Will write the developer to let him know. This is all working on the bugfix version of Marlin.