Octoprint fails at Admin User Creation during the Setup Wizard

What is the problem?

I want to setup Octoprint on a semi-old Rock64 Board I have lying around. While getting it installed is no problem (I already did so on my Banana Pi M2 Ultra, although that seems to have too weak a PSU for Wifi, Camera and Octoprint), I cannot complete the setup wizard.

I create my Admin User with a password and immediately get the error popup in red that the Login with this user has failed. I could continue the wizard, but the Online Check UI will not continue to do anything. Buttons pressed do not react and clicking on activate/deactivate opens two instances of the same popup telling me that I have to complete this step.

Killing the server and restarting it brings me to the login page, but the password I set is not working. The users.yaml file exists and has an Entry with the corresponding Username and an encrypted password.

What did you already try to solve it?

Reinstall Octoprint, in a venv as well as with root privileges, switched from raspbian jammy to bullseye and tried the same procedures there as well.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

Not at all, still the same message of Username or password incorrect.

Systeminfo Bundle

I cannot access the systeminfo bundle :frowning:

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

octoprint 1.8.7
armbian 23.02.2 Jammy
Linux 5.15.93-rockchip64
Chrome, Vivaldi (Chrome Engine), Firefox all used under windows.

You can still get it through the command line

A user found this issue on discord a short while ago, and after some investigation it seemed that the argon2 lib that's on the RockPi was faulty, even outside OctoPrint it wasn't working. It wasn't able to properly verify the hashes it created.

There's not much by way of a workaround, and it didn't make it in time for the upcoming 1.9.0 release either by the looks of it.

Thank you for your quick reply. At least now I know that my sanity is still intact. Maybe I can build a version from the repository with the fix in it.

I put in my changes from the PR directly into the file and used the setup wizard. After that it shouldn't matter if you update because it will try all available hashing algos to check the hash.

I really tried to find out why this fails but it has probably something to do with some low level optimization that doesn't quite work on the Rock64. It even failed when I tried the hashing lib in C. After that I just gave up.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.