Octoprint falling


#1

What is the problem?
My printer was unused for about 2 months (raspberry was still on this hole time though) and it was working just perfect before!
Yesterday I turned it on again, printed a 20mm cube with no problems and stared a 35h long print.. 5~10h in, this happened.. Octoprint just stopped working and the control box still shows "printing..." With temps still high as it was really printing..

What did you already try to solve it?
Took raspberry power cable out, connected again and tried it again today.. And 5~6h in, it happened again!

Tried to connect to the raspberry pi via Putty and it says that the host doesn't exist.

Ill have to turn it off and on again, but I dont want to waste another 5h~ just for it to stop working again

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)
Octoprint 1.3.9
Octopi 0.15.1
Raspberry PI Model 3
Printer CR-10S
Firmware TH3D U1.R1.9b with ezabl

I've posted it in a Facebook group and a guy said he has been printing for some weeks and today he got the exactly same problem!

Log File: octoprint.log (1005.5 KB)


#2

Honestly, if you left the Raspberry Pi on for two months then it's possible that a memory leak could cause some problems.

With most IoT (Raspbian) style of single-board computers, it's probably a good idea to at least turn them off once every two weeks. (I've got a proxy server running all the time and it wants a reboot perhaps once every three months because it's gone stupid. It is to be expected.)


That said, it appears that your problem is now persistent.

The Creality line of printers seem to have more problems than others. My gut's telling me that this is either power/heat related and the Raspberry is unhappy as a result or that it's serial-related and this is causing problems.

  • 2.5A 5V power adapter for the Raspi?
  • The Raspi isn't throttling because it's too hot?
  • Your serial cable either has an internal metallic shield or it's got ferrite cores on it?

#3

2.5A 5V power adapter for the Raspi?
Yes, that`s correct

The Raspi isn't throttling because it's too hot?
No, it`s not.. I did install heat sinks and a small colling fan as well that came with the case I bought

Your serial cable either has an internal metallic shield or it's got ferrite cores on it?
Honestly, I have no ideia.. I`m still using the "blue" one that came with my CR-10S


#4

Ferrite cores are pretty obvious. Look for the boxy thing on the cables here.

Internal shielding is more difficult. If you try to flex the cable using your fingers, you can sometimes feel the resistance to bending and even feel the metallic shielding that's sliding inside the insulation.


#5

It's internal metalic shield then


#6

There's a lot of complaining in your octoprint log about something called backoff and another called anywhere. Try starting OctoPrint in Safe Mode and see if it's now happier. If so, one of your plugins is to blame.

There's also this:

2018-09-11 21:46:11,513 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Heating failed, system stopped! Heater_ID: 0
Recv: ok T:-15.00 /0.00 B:22.16 /0.00 @:0 B@:0

If I'm reading this correctly, the thermistor on your hotend is reporting -15 C which is probably wrong.


#7

So I start it in safe mode and try to print again? Or just start it and get a log or something?


#8

Start in Safe Mode, see what the temperature query is reporting back. It's something like an M105. You want to see something more like T:20 or T:30.


#9
2018-09-11 21:46:11,513 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Heating failed, system stopped! Heater_ID: 0

If I`m right, this one might be because I tried to print with the heat-end cable unpluged (I was changing the cable management).. I just turned the printer off, plugged it in again and started the print

As soon as I did that, temps came back to normal.. That one was my error, not octoprint.. hehehe


#10

Before sending any commands to preheat the extruder, you should reasonably see "room temperature" from that thermistor report. You'd be in the Terminal tab for this.


#11
Send: M105
Recv: ok T:24.88 /0.00 B:23.81 /0.00 @:0 B@:0

See.. It was my error.. Cable was unpluged. I dont think it have anything to do with the other problem Ive got..

Just started it in safe mode.. I`ll try to print it again now


#12

Hang on. Before starting a print, I think I'd make sure that it responds nicely to temperature-settings commands.

On the Temperature tab, set it to preheat for PLA, for example. Now go back to the Terminal tab and watch the temperature report back.


#13

It does.. I`ve printed a 30min 20mm cube as soon as I turned the printer on after the 2 months pause and it came out perfect (I was watching temps and everything while it was printing)
And after that it printed for 5h~7h before the error without problems..
Also, the second time I tried, it printed again for almost 6h without problem, but then I get this error lol

I'll preheat it now just so you can see the report


Recv: ok T:38.48 /215.00 B:24.09 /70.00 @:127 B@:127
Send: M105
Recv: ok T:42.11 /215.00 B:24.00 /70.00 @:127 B@:127
Send: M105
Recv: ok T:47.25 /215.00 B:24.56 /70.00 @:127 B@:127
Send: M105
Recv: ok T:52.02 /215.00 B:24.66 /70.00 @:127 B@:127
Send: M105
Recv: ok T:57.08 /215.00 B:24.78 /70.00 @:127 B@:127
Send: M105
Recv: ok T:62.75 /215.00 B:25.00 /70.00 @:127 B@:127

#14

I know for my Cura slicer, it will keep the hotend fan off for the first, say, five layers to allow some bed adhesion to happen. Then it should turn the fan on full and keep it like that until the job is done.

Good. We see the temperature climbing slowly.


#15

Mine do that for the first 2 layers, if I remember it right


#16

You've got a heated bed, so it can start sooner.


#17
Send: M105
Recv: ok T:214.53 /215.00 B:41.17 /70.00 @:62 B@:127

I'll start the print now.. Let's see if it does the same in SafeMode
Edit: Not now.. But when it reaches the right temps.. hehe


#18

Good luck. I hope it works out this time.


#19

Thank you!
If it work out, I'll disable the plugins and enable 1 by 1 the ones I "need" to see if I get something


#20

The two which I saw failing are backoff and anywhere. (Read the octoprint log and see what you think.)