Octoprint Goes offline

Octoprint goes offline often--- sometimes during print

What I have done :
Raspberry Pi3B
New SD Card
Fresh new Software install
New 3A Power Supply
Removed PI from case
Hard Wired
Firmware 1.8.6
CR10 Smart Pro
I have 2 other units with same exact specs running same firmware, same cables, same plugins, Etc
1- Other Smart Pro
1 - Ender 2 S1 Pro
These do not display same issues.
Logs attached:

Can someone PLEASE help me get past this issue?
octoprint (1).log (177.4 KB)

Well, I reviewed your log file. Nothing sticks out as a detectable issue in the log. Well not to me anyway. I am not sure by your issue description if you are saying that the Raspberry Pi is the thing going offline(Reboot, rest, unresponsive/other) or if OctoPrint is losing its connection to the printer or maybe OctoPrint service is stopping. "offline" can mean so many thing to a user/operator. Depending on what you mean by "octoprint goes offline", one might be able to point you in a direction.

Have you run it in safeMode? If not, you could try that. It might isolate it to being related to one of your plugin's. Well that is if the issue goes away.

If you mean that OctoPrint is losing its connection to the printer, it could be a cable issue. But it would likely show up in the log.

If you mean that the OP Service stopped, it could be RPi hardware related, over heating or something. Again if its a slow build up issue it might show in the log in some way.

If the RPi is simply shutting down,that would account for the fact that the logs show nothing. If this were the case, I would suspect an OS Setup issue. Maybe the OS is going to sleep? If you are using the standard OctoPrint image, that is not likely. You dont list what image you used.

I first suspect the following issues, outside of Octoprint:

  1. Loose power cable to the raspi
  2. Bad USB power cable to the pi
  3. Bad power adaptor to the pi
  4. Bad raspberrypi components (there are sometimes chip-level issues, swap and see), this was especially true of the Raspi 3 versions. I have received a number of wonky units ( however, I was also ordering 200 at a clip, so YMMV).
  5. bad write to the SD card - errors in writing to the SD card will pose problems, make sure the write is clean, run a verification of the write to ensure it is OK. Also - use a different SD card.
  6. network drops due to IP address issues -- keep a ping running continuously to the pi.
  7. DNS issues - if a network request hangs due to a DNS query, this could cause some weirdness if not handled properly from within Octopi. Use wireshark to see it's regular traffic, see if you spot a pattern.
  8. Heat-related problems -- the Raspi could be getting too hot, it will shutdown and restart when it does.
  9. Accidentally overclocked -- the raspi boot script defines the proper frequencies that the ARM chip should run at -- if it's been overclocked it might work for a short period of time, but it'll probably be unstable and break like you've described. Refer to the Raspi boot configurations to set a nominal power and speed.

Good luck !

In worst case: broken system due to power cycling the Pi:

2023-03-29 06:51:11,022 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2023-03-29 06:51:31,613 - octoprint.plugins.tracking - INFO - Sent tracking event ping, payload: {'octoprint_uptime': 22527, 'printer_state': 'PRINTING'}
2023-03-29 06:52:10,132 - octoprint.startup - INFO - ******************************************************************************
2023-03-29 06:52:10,137 - octoprint.startup - INFO - Starting OctoPrint 1.8.7
2023-03-29 06:52:10,164 - octoprint.startup - INFO - ******************************************************************************
1 Like

Sorry for delays. I have 2 other printers rhag work so I have been using them. This one

When I login via web GUi.

It’s offline.

I have tried safemode.
I have changed PS
I have changed card
I have changed to another PI
I have changed all cables

It goes offline sporadically. Sometimes after one print. Sometimes after a few. Sometimes in the middle of one after a fresh reboot. .

I am going to build a fresh image with no third party apps. And report back after a few days. I will build this tomorrow.

I’m really bad at SSH and RPI. I will grab a windows laptop and putty.
I have tried two PIs with the same issue. So. I thought it was a third party app but, my other machines run the same apps.

Same PI also.

So. I booted in safemode. It continued to happen but in less frequency. Not sure if this was a placebo effect.

Creality printers are infamous for EMI related communications errors. They are also infamous for being EMI generators. High quality, shielded, short USB cables with Ferrite beads help but don't always eliminate the problem. Rerouting the cables within the printer sometimes helps. Search this forum for "EMI" and you will find multiple topics on the subject along with many options to try.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.