Octoprint interface has squares where words should be

What is the problem?

Octo interface not loading correctly

What did you already try to solve it?

tried two computers, both using chrome

Have you tried running in safe mode?

no

Did running in safe mode solve the problem?

na

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
browser.user_agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/106.0.0.0 Safari/537.36
connectivity.connection_check: 1.1.1.1:53
connectivity.connection_ok: True
connectivity.enabled: True
connectivity.online: True
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: True
env.hardware.cores: 4
env.hardware.freq: 1200.0
env.hardware.ram: 914006016
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 3 Model B Rev 1.2
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.octopiuptodate_build: 0.18.0-1.8.4-20220927151125
env.plugins.pi_support.throttle_check_enabled: True
env.plugins.pi_support.throttle_check_functional: True
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: True
octoprint.last_safe_mode.date: unknown
octoprint.last_safe_mode.reason: unknown
octoprint.safe_mode: False
octoprint.version: 1.8.6
printer.firmware: Marlin TH3D UFW 2.32 (Aug 11 2021 15:54:39)
systeminfo.generated: 2022-10-19T18:06:44Z
systeminfo.generator: zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Everything seems to be listed above. Using Latest Chrome. Tried on Windows 10 and Mac osx Big Sur

Almost forgot

So it seems something is loading.

Please provide the systeminfo bundle in your next post.
And please try safe mode.
And try a different browser.

This question could really do with a better description of what is wrong. The title of the issue contradicts the screenshot you posted, which seems to show the OctoPrint interface, so it did load. Try and describe in as much detail as possible what your issue is, and then you will be able to actually get help with it.

Yes its loading but i have a bunch of squares where words should be.
I included what i thought was the systeminfo report. What else do i need to provide. Do i need to upload all of the files that came with system info download. Its like 6 text files?

That's why I asked you to run in safe mode.

For your info:

Just upload the zip-file you download there.

Wow you guys aren't very friendly here are you. Shame.
I truly apologize i didn't read the fine print. This is my first time EVER requesting help, and potentially my last.
Tried it on firefox with same results. Can't boot in safemode due to long print running now.
octoprint-systeminfo-20221019172818.zip (147.7 KB)

Updated, does that help?

Can't boot safemode right now, long print.
Tried Firefox- same result.
Cleared Cache on Chrome, never use firefox so no cache to clear.

Kind of snarky for someone that is asking for help

Jeff, a very small group of very helpful people here are fielding support requests from a community of hundreds of thousands of users worldwide. Every day. For free. And are often repeatedly answering the exact same questions and solving the exact same problems for people.

But they cannot help you if you leave them without crucial information like the systeminfo bundle, and at least a tiny amount of collaboration is expected from people asking for help in that they do some prior testing in safe mode first and at least fully fill out the support request template, including attaching a systeminfo bundle. And asking them to help you when you fail to take the time to do that isn't a very friendly thing to do on your part. Good way to demotivate volunteer folk who just want to help strangers. Shame.

3 Likes

I’d be trying the following things:

  1. Check all of the config files for octoprint/pi.

  2. Reinstall octopi. What regional settings do you have on your octopi ?

  3. What other updates have recently been made on your Raspbian ?

  4. What updates have recently been made on your Mac ?

  5. By your description it seems like the octopi page is not being correctly rendered by your various browsers that you have tried. But for purposes of assisting you please stick with Chrome on your Mac. It’s a level playing field.

Using chrome it’s possible to view the html source code for the octopi page that’s displaying squares instead of proper characters.

You can search through the html source to find where you see squares on the rendered page. Do you see the expected text within the html ?

It’s hard to visualise your problem.

Please put up a screen shot of the octopi page that shows the squares where you expect text. I am wondering if ALL the text on the page is not being correctly rendered or only some/parts if it, and if so, which parts.