Octoprint is showing Python 3.7.3 when I've updated Python to 3.8

What is the problem?

I have been running Octoprint 1.7.3 on Python 3.7.3 and Octopi 0.18.0. I wanted to install a Plugin that requires Python 3.8. I manually updated Python to 3.8 via SSH (I am NOT a programmer by any standards. I followed a how-to guide that details how to do the update via Windows and SSH. It seemed to install correctly and I even verified 3.8 was the default system. When I restarted my pi and loaded OctoPrint, it's still showing Python 3.7.3.
I did save a backup of my OctoPrint before I did anything, so I have that in case of an emergency.
Link to the How-to that I followed: Install Python 3.8 on a Raspberry Pi easy to follow guide

What did you already try to solve it?

Already tried restarting the OctoPi several times. I don't know any tricks beyond that.

Have you tried running in safe mode?

No. I'm printing a 17 hour part at the moment so I can't restart.

Did running in safe mode solve the problem?

I'll have to wait until tomorrow to try.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

browser.user_agent : Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/99.0.4844.82 Safari/537.36

connectivity.connection_check :

connectivity.connection_ok : True

connectivity.enabled : True

connectivity.online : True

connectivity.resolution_check : octoprint.org

connectivity.resolution_ok : True

env.hardware.cores : 4

env.hardware.freq : 1400.0

env.hardware.ram : 915718144

env.os.bits : 32

env.os.id : linux

env.os.platform : linux

env.plugins.pi_support.model : Raspberry Pi 3 Model B Plus Rev 1.3

env.plugins.pi_support.octopi_version : 0.18.0

env.plugins.pi_support.throttle_state : 0x0

env.python.pip : 20.3.3

env.python.version : 3.7.3

env.python.virtualenv : True

octoprint.safe_mode : False

octoprint.version : 1.7.3

systeminfo.generator : zipapi

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint 1.7.3, Octopi 0.18.0, Creality Ender 3 Pro, Marlin 1.1 (never updated after buying the printer in 2020)

I just spent the last 2 hours on the same thing wanted a plugin that says it needs 3.8 I just found this page that says it only supports up to 3.7

OctoPrint currently supports Python 2.7, 3.6 and 3.7.

I think you have to create a virtual environment for 3.8 or I was trying 3.10 and install it to that. If someone knows how to do that the info would be great as I use linux only with the help of tutorials

Hello @Mitch_Yurkovich !
Hello @Micah !

You have to update the Python in the virtual environment (venv) of OctoPrint.

You may look here:

I'm just curious what plugin is needing Python 3.8

And @Mitch_Yurkovich : BTW

OctoPrint does support more than Python 3.7, the PyPi page is outdated and is already fixed for the upcoming 1.8.0 release. For 1.7.x, that is 2.7 and 3.6+ (up to 3.10) and for 1.8.x it is 3.7+ (up to 3.10).

You have to recreate the OctoPrint venv, it's own Python environment for OctoPrint to run under a different version.

You can do this by creating a backup in OctoPrint's settings, deleting the env at ~/oprint and re-creating it using virtualenv, then restore your backup.

Alternatively, use the OctoPi 1.0.0rc image, which comes with Python 3.9. 32 bit recommended, and there are one or two issues but nothing major. Find it here.

The OctoPrint Wyze plugin released recently.

1 Like

Thank you @Charlie_Powell and @Ewald_Ikemann! Charlie, yup, I was looking into the OctoPrint Wyze plugin. Hoping it'll help my Wyze Cam work better with my printer. It's turning into more work than I bargained for. When I get some time I'll try to recreate the venv. Thanks for the help!!

Thank you for the help regarding the Systeminfo Bundle. You can tell I'm new to posting on the OctoBlog. Finding it REALLY helpful though!

Hi @Mitch_Yurkovich. I wrote the OctoPrint-Wyze plugin and I've already helped a few people set up new Python environments so they can use it. See here for an in-depth Q&A that you may find useful: Installation Issues, Clarification Requested · Issue #5 · eshapiro42/OctoPrint-Wyze · GitHub.

I'm happy to assist if you still need help! That being said, I'd like to reiterate that this plugin is really just for automating your Wyze devices turning on or off (no support for camera controls or video streams). Just to make sure you don't get your hopes up and go through all this effort for nothing!

Thanks for clarifying @eshapiro42! That helps me decide not to try to "fix" anything further. I was hoping the plugin had more functionality for the camera controls. At least this helps me save time I'd otherwise needlessly spend on the issue.

Glad I could "help" in that regard at least. I'd love to add more functionality into my plugin down the road but Wyze has unfortunately not made things easy for the open source community.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.