Octoprint keeps crashing and leaving hot end on

I have a Pi 4b 2 GB running octoprint 1.5.3 and i can stay connected for a long time but once i start printing, it stops responding which leaved the hot end running until i notice. It might run for several hours even over night, or itll fail after 10 layers. I cannot ssh into it after its crashed and the only way to gain access again is to power cycle, which i know can cause corruption but i dont have much choice with no access.

What did you already try to solve it?

Upgraded apt through SSH, removing plugins 1 at a time, swapping USB cables, taping over 5v pin on usb, switching USB ports, using ethernet, using raspberry pi branded usbc power supply, reflashing octoprint on 3 different sd cards (all high quality 32gb), switching baude rates. Ive been scouring the forums for advice but nothing helped.

Have you tried running in safe mode?

Yes print failed

Did running in safe mode solve the problem?


Complete Logs

octoprint (2).log (455.3 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

octroprint 1.5.3
octopi 0.17.0
creality ender 3 pro
firmware: (2019.11.13)Ender-3 Pro1.1.6BLTouchV3.1PowerLossContinueEnglish
browser edge and firefox (cannot view webcam through firefox)
windows 10 pro

2021-01-20 20:33:35,745 - octoprint.util.comm - ERROR - Unexpected error while reading from serial port
Traceback (most recent call last):
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 3831, in _readline
    ret = self._serial.readline()
  File "/home/pi/oprint/local/lib/python2.7/site-packages/octoprint/util/comm.py", line 6455, in readline
    c = self.read(1)
  File "/home/pi/oprint/local/lib/python2.7/site-packages/serial/serialposix.py", line 501, in read
    'device reports readiness to read but returned no data '
SerialException: device reports readiness to read but returned no data (device disconnected or multiple access on port?)
2021-01-20 20:33:35,794 - octoprint.util.comm - ERROR - Please see https://faq.octoprint.org/serialerror for possible reasons of this.

So definitely want to make sure there is no backpowering (tape on 5v of USB cable) with the Creality boards. It could boil down to Creality's crap firmware. Highly recommended to flash official Marlin rather than use theirs. Printers known to ship with broken or unsafe firmware, or broken electronics

oh, and do you have an sd card in the printer?

so.... the bltouch firmware is a no go? the question i have is can i still use octoprint to auto bed level with standard creality firmware?

and i did up until like 30 minutes ago coz i was messign with the card

Any firmware that has been provided by Creality is suspect. Whatever firmware you use will have to support auto bed leveling in order for you to utilize it, OctoPrint doesn't control that, it just sends commands to your printer.

you might consider trying to flash octopi 0.18rc2 32 bit just to see. the problem sounds like the power is just dropping out on the pi and it's disconnecting since you can't SSH to it.

i already tried .18. first as a 64 bit on an 8gb pi then the 32 on the 2gb pi and i was having the same issues. but why would using 0.18 fix the power failing? i mean im using the pi specific power supply

Yeah, ok. You already tried, same issue. The only thing that has remained constant is whatever firmware you have installed? It might not be losing power, but you said you couldn't SSH to it, so I'm only going by what could be the cause. Whatever it is, it's the printer itself that stops responding to OctoPrint and therefore OctoPrint disconnects because there is no connection for it to communicate on anymore.

so i couldnt ssh into it this time around. this is new as of today. before i was able to and frequently edited using putty.
but yes firmware the same, sd card in the printer itself (until this morning). and on top of that ive been printing in safe mode for the last couple hours and it just shut down on me mid print again. and once again it just stops responding and doesnt restart itself and leaves the hot end running

ok... ok.... after going through one of the deepest rabbit holes ive been down yet. I THINK i found the reason. the firmware that creality put out for the bltouch is terrible and doesnt play well with octoprint. I updated to marlin (i had to edit and compile the firmware myself) but it seems to be working. now i just have little issues of the camera timing out but restarting the webcamd service in ssh seems to fix it.

If this turns out to be stable ill report this thread complete ad add some links that helped me

I know you said it's the rpi USBC power supply, but what is it's rating? Do you have anything else connected to the pi? Did you possibly tape the - in the USB instead of the + pin?

lol...isn't that what I said from the beginning?


Hello.. I have Ender 3 Pro upgraded to 2.4.7 board and BLTouch with v2 screen. Added PI 4 8G with OctoPi 0.18.0 nighty. I was printing without issues and had updated Firmware in the printer to manage BLTouch w Marlin. All was healthy! I connected the Pi with Octoprint and then BLTouch crashed into bed when I sent command to print. Took Connection cable off and tried to run through Ender panel. It now crashes as if Octopi changed the Default G code in the Ender firmware. Scratching my head.. going to pull the Ender G code to see difference between what I have on file.

Any known issue or visibility would help,

Any logs would help too :wink:

1 Like


I had to update my Ender Config with Marlin.. and the printer is back up and running. I have not connected it back to the Octoprint server yet as I need to get some prints done. Will try and reconnect after I check the Octoprint configs.


browser.user_agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/87.0.4280.141 Safari/537.36 Edg/87.0.664.75
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 8136028160
env.os.bits: 64
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 21.0
env.python.version: 3.8.6
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.5.3

just the pi cam and the printer and yes i did do that tape thing

so..... long story short:
I flashed official Marlin software and fought with it a long time to get it running but it was still crashing randomly the exact same way. I found a super obscure bit of information related to the serial connection and after i activated "wait for start on connect" under settings>serial connection>firmware &protocol>protocol fine tuning.... it suddenly stopped crashing. I also increased the intervals and timeouts a bit just to be sure. but its been printing 13 hours without a stutter so i think tat was the problem all along