OctoPrint locking up Lulzbot Taz Workhorse

Hello! I'm new to 3D printing. We acquired the printer some time ago, then COVID shut us down for 6 months. I came back, updated the Pi/OctoPrint softwares to current, and set everything up. It works great directly connected to a Laptop/PC via USB. OctoPrint locks the printer up solid about 3 seconds after connecting.

What is the problem?

OctoPrint locks the printer up about 3 seconds after connecting to my Lulzbot Taz Workhorse. It locks up, as in the scrolling status at the bottom of the printer LCD stops scrolling and the printer will not respond to any movement of the scroll/push button wheel. This sends the printer into a thermal runaway state, since it seems to begin heating the hotend, then locks therefore never stopping the heating. The only solution is to manually power off the printer using the power switch. SOMETIMES it connects and then will print. Most of the time, the printer locks up. I have a serial.log of a successful print, followed immediately by a lockup as soon as connecting.

What did you already try to solve it?

I have tried multiple USB cables, I have moved the Pi to a location away from any potential interference, I purchased a new and very well rated 5V 3000 mA power supply. I have updated the Pi, Octoprint, and printer to current softwares/firmwares. I have been up and down the forum trying many of the things others say helped them. I am running nothing but the bundled plugins.

I have also tried increasing the timeout durations to the maximum I felt was acceptable.

Complete Logs

I have attached a serial log of a successful print followed by an unsuccessful print, the octoprint.log before updating octprint/python, and a serial log from today of an immediate failed print (after a new powersupply)

octoprint old_and_new.log (234.8 KB) serial log working and not working.log (2.2 MB) serial failed today.log (21.1 KB)

Thanks!

(PS: I JUST saw the right panel with the "your topic is similar to." I'm going to go ahead and submit this, so I don't have to redo it in the event it doesn't work, but will update if removing the SD Card solves the lockup issue since there doesn't seem to be any definite closure on that thread.)

Edit: I removed the SD card, connected, and it is printing. I'll update if this is consistently the case.

I was just about to say to please search the forums as that sounded really familiar and then I saw your PS and Edit ^^

After many successful prints and even more successful manual connects/disconnects I think it's safe to say an installed SD card in the Lulzbot Taz Workhorse interferes with OctoPrint's connection to the printer.

Removing the SD card has produced flawless results. Thanks!

Just out of curiosity, has this problem been reported to LulzBot support? I believe that once they know about it, they will fix it.

I posted this as a solution in their forum this morning. I'll see about submitting a ticket/emailing support as well.