Octoprint no connection to web-interface

Hi everybody!

I'm new to Raspberry / Linux and hope that you can help me with my problem...

What is the problem?
I'm already using OctoPrint for a while, but now I can't get access to the web-interface.
I just see the page " The OctoPrint server is currently not running". The last time it worked was on 2020-06-08 via Telegram Plugin (see logs).

What did you already try to solve it?
I logged in to the Pi via SSH and directly via monitor and keyboard. Then I tried to verify if a process is running with the following code, but nothing happened.
ps -ef | grep -i octoprint | grep -i python

Please see the attached screenshot.

Additional information about your setup
Printer: Anet A8
Firmware: Marlin
Raspberry: 3B+
OctoPrint Vers.: 1.4.0
OctoPi Vers.: 0.17.0
Browser: Firefox

Thank you very much in advance for any help!

In addition to the general information you did supply, we really do need the actual log files to help. Note that everything in blue in this response is a link to additional information that will help you gather and provide what we need to help you.

Need help? Read this first! Remember to provide version numbers, relevant log files and general information about your setup. Problem solved? Mark the solution! WE NEED LOGS TO HELP YOU!

Thank you very much for your reply @b-morgan!
I have now copied all required log-file and you will find them attached.
I really appreciate your help!
log-files.zip (1.1 MB)

@FreeWilly, Thanks for uploading the logs. Unfortunately, I can't see what the problem is so we will have to call in @foosel as she can probably suggest how to proceed.

All I can tell you based on these logs is what we already know - the server hasn't been running since June 8th.

That "The server is currently not running" page gives you a couple of commands to run. Try those, and also try SSHing into your Pi and doing this:

sudo service octoprint stop
~/oprint/bin/octoprint serve --debug

This would try to start OctoPrint manually and in your shell (Ctrl+C to stop it again). It will hopefully print a helpful error message that allows to narrow down on what's wrong.

Thank you, Gina :sweat_smile:

If I can add to the commands @foosel suggested.

screen -L
sudo service octoprint stop
~/oprint/bin/octoprint serve --debug

and after the Ctrl+C


This will create the log file screenlog.0 which you can then upload here.

Thanks again @b-morgan and also @foosel!
When I enter the commands the following happens:

Or when I directly enter it:

Sorry, I am really new into Linux and Raspi....
Thanks for your help!

@FreeWilly, In the first case where you did a cd oprint/bin, you would need to type ./octoprint because the current directory is not on your path. the ./ tells Linux exactly where the file is located so it skips looking for the file on the path (echo $PATH)

In the case where you type ~/oprint/bin/octoprint, this again tells Linux exactly where the file is located.

Coming from Windows, I had a hard time with this in the beginning. After a while, you get used to it :grinning:

Unfortunately, I'm still not able to help with the actual problem, but @foosel should be back to give additional guidance.

Thanks for the detailed explanation.
For the rest of the week I'll be very busy with my work, so I won't have time to "play" with OctoPi...
Next week I will test what you have just written and the get back to you.
Thanks again for you patience and your help!

Looks like a corrupted install. If you are in the habit of pulling power without proper shut down first, you really should stop doing that.

Try fixing it with

~/oprint/bin/pip install --force-reinstall OctoPrint
sudo service octoprint restart

If that doesn't solve it is time for a reflash, best on a new card just in case.

Thanks again for your answers. Yes you are right @foosel, in the past I just turned off the power without proper shutdown...
I tried what you mentioned in your last message, but unfortunately it didn't work.

I will now reflash my SD-Card and in the future I will always shutdown OctoPi before turning off the power.
Thanks for your help!

Typo in your screenshot there... that should be

~/oprint/bin/pip install --force-reinstall OctoPrint

You have

~/oprint/bin/pip install --force reinstall OctoPrint

Ok thanks... :man_facepalming:
I will do the reflash anyways.