Octoprint not booting, Kernel Panic

I am trying to set up octoprint on my raspberry pi b+, but it fails to boot everytime I plug it in. I followed the directions exactly, and I have the latest version of octoprint. I have tried plugging in a keyboard and monitor to troubleshoot and this is the screen I get:

Things I have done to troubleshoot:

  • formatted and reimaged the card many times, using both Etcher and win32
  • replaced the sd card and power supply
  • downloaded the most recent and older versions of octoprint
  • everything on the wifi troubleshooting page pretty much
  • ATTEMPTED: the steps to fix kernel panic (179,2), but my keyboard and my roommates keyboards won't type anything
  • Installing NOOBS to see if it was my pi, but NOOBS ran perfectly (including my keyboard)
  • Wifi adapter has worked on the pi before, and currently works on my desktop
  • plugged in Ethernet instead of wifi adadapter

But everything results in this same screen...

I am using octopi 0.15.1 on a raspberry pi b+ v1.2. My power cord is 5.1v and 2.5A. My sd card is samsung evo plus 32 gb. My printer is a monoprice select mini v2.

I feel like I have tried everything and am getting pretty frustrated at this point, so thanks in advance for any help.

We've actually seen this once before:

I assume that's what you are saying under "ATTEMPTED". Have you tried different SD cards?

1 Like

Obvious you can not type in anything because the Pi did not boot up completely and hangs there where it is.
I assume you got OctoPi from here. (Who knows what's already in the net)
And as stated by @tedder42: try another SD card. Even new ones can be faulty.

Correct, I did download it from there. Also I have tried two different SD cards so far

Make sure to follow the instructions and use something like Etcher to burn the image to the microSD.

Sorry for the confusion, but I attempted these steps and I couldn't type at all. I also found that forum, and I have already tried two SD cards, including buying a brand new one that was recommended on several sites

I have tried etcher and win32 so far and both had the same results

There's an SD card slot in my MacBook and I'll then insert the microSD into the SD adapter and then into my Mac.

In the past, I've also used devices which have a USB plug on one end and then several slots in them. You find the microSD slot and plug it in there.

In all cases, it's important to choose the Eject feature so that what is written makes it to the media. The kind of error you're seeing suggests to me that the Etcher software wasn't completely successful in doing its job.

At the end of an Etcher burn session, it should have safely ejected the media. Once you put it back into your MacBook (or Windows) workstation, it should only be able to safely mount the first FAT volume on the microSD. There is, however, a second EXT4 partition on the microSD and this is the part that's failing during bootup.

If you have a different computer, you might try doing this on that one instead.

Hi! This is my first post here and unfortunately I have the same issue. I have tried the followings:

  • downloaded the latest Octopi
  • 3 different SD cards (4 Gb, 8 Gb and 32 Gb)
  • writing image with Etcher and Win32DiskImager
  • microSD card in my laptop's MicroSD slot and USB card reader
  • I have a Raspbery Pi 3B

After several attempts I still get the same error.

What should I try next?

I have tried to boot the RPi with an SD card with Raspbian, but I have the same error.

Please help.

@Kixman The final line says it all, it can't mount the root volume.

Read more

Try starting over with the 8GB microSD. Download the OctoPi image again (manually this time) but don't unzip it.

curl -o ~/octopi.zip https://storage.googleapis.com/octoprint/stable/octopi-stretch-lite-0.15.1.zip

I would suggest using Etcher over Win32DiskImager. (Etcher will dutifully Eject the media after writing both partitions, minimizing any ext4-corruption.)

The assumption is that something is corrupting the zip file you download or is corrupting the uncompressed content or something else. Simply allowing Etcher to unzip this may be the fix.

If you're using Windows then make sure that you edit the /boot/octopi-wpa-supplicant.txt using Notepad++ rather than anything else.

Hi @OutsourcedGuru! What do you mean by "download manually"?

@OutsourcedGuru Thank you for your advice. It solved my problem immediately. I did everything as you recommended (including the manual download :grinning:) and I am using my initial 8 Gb micro SD card.

Thank you again for your support.

1 Like