OctoPrint, OctoPi and the Raspberry Pi 3+


this morning i have running the octoprint nightly 0.15,and it works now
0.14 will not working for me.
but if i press print knob in octoprint,then the print is blue en still blue,en not the cancel or pause.
sorry my english is not good :stuck_out_tongue:


I was semi-stupid and got the 3 b+ and now the link for nightly builds does not work atm.. http://gnethomelinux.com/OctoPi/nightly/



Probably due to this

Until the page comes back up, this image at least was reported to work on this OctoPi ticket.


Hello guys, I got an RPI B+ and installed the Nightly Builds "2018-03-23_2018-03-13-octopi-stretch-lite-0.15.0.zip" on that...
But, on the download page I see the new version: 2018-03-26_2018-03-13-octopi-stretch-lite-0.15.0.zip, so the question is, how I get the update from my version 2018-03-23 with the new relese 2018-03-26..???
I need reinstall all things or the sistem is able to update it...?
Thx for your help...


Hi, I have just found Octopi and have tried loading it on to a Pi 3+, however no joy.
After creating an SD card with 0.14 and powering it up it appears to have a problem as the red LED flashes a pattern. I haven't had time to attach a screen yet, but intend to do so tomorrow. If wanted I will supply the screen messages.



@Macca45 I suggest you read the article again which clearly states that OctoPi 0.14 won't work with the Pi 3+ :wink:


Yes I had just found that where you said you did not expect it to work. I was merely confirming that it doesn't work.


Ah, ok then. It sounded more like "why isn't it working" - and you wouldn't believe how many people already actually didn't read the article and then opened up support requests, hence my assumption this was the case here as well.

split this topic #20

A post was split to a new topic: Installed OctoPi on Astrobox, can't connect to my WiFi


For image updates you usually need to reinstall. If it's just a new base image, the usual ways of updating a Raspbian image incl the kernel might be enough though.


So I just got a 3+ and trying to print with octopi/octoprint. I don't think the latest stable one works... I got the image in via both etcher and windisk imager and when I put the card in, I get a flashing red light and rainbow screen... Going to try a nightly now :frowning:


seem OK
=> boot OK , wifi OK


As a point of information, bought a new Pi3+ to run OctoPrint, but the Pi would not boot. Seems a setup that supplies ample power to the older Pi3 does not work. So there is something different in the power requirements of the new Pi3+. Have not yet puzzled out the difference.

Swapped in an older Pi3, and now have OctoPi running (my first use of OctoPrint).


Pi3+ needs a completely different build, libraries and drivers. Using anything below the nightly Octopi 0.15 builds will not work. It’s not power, just a different chipset.

It requires a later version of Rasbian and NOOBS too. You cannot take a build for a previous Pi version and plug the card in. The 3+ just won’t boot with any of them.

It’s a start from bare rebuild. The good news is that Octopi 0.15 builds work just fine. I just added the desktop GUI to make configuring the WiFi/LAN easier at the time.


For what it's worth, I downloaded the latest nightly OctoPi image onto a microSD card and threw it into a Raspberry Pi 3 B+, edited the /boot/octoprint_wpa_supplicant file (making sure to edit the wi-fi country at the bottom) and it joined my wi-fi without problems.

I also note that I next ran sudo raspi-config from an ssh session and the wi-fi country in the localisation section was still GB so I set it to US (as well as the timezone, locale...)

split this topic #27

7 posts were split to a new topic: Getting a touchscreen to work on OctoPi 0.15.0 running on an RPi3+

split this topic #28

A post was split to a new topic: I have a new Pi 3+. I cannot get Octopi to do anything



This is my first time here
I am about to invest in a 3D printer and would like to get OctiPi

I am thinking of getting the Pi3 B+ from Amazon. But was reluctant when I saw a few folks had issues.
Looking at the latest build (0.15.1) I see that 3+ is included (see attached image). Does this also include the 3B+

Thanks in advance!


Getting a touchscreen to work on OctoPi 0.15.0 running on an RPi3+

Never mind
I found my answer



The limitation in printing speed you have is a product of your printer not the Raspberry Pi