OctoPrint Server is Currently Not Running on OctoPrint 1.7.2


I have the common "The OctoPrint server is currently not running" problem. I have seemingly tried everything I can think of (that I know how to do). It is worth noting I'm not 100% familiar with how exactly the system functions.

What did you already try to solve it?

  • Verify the Process is running, it is not, no return after running ps -ef | grep -i octoprint | grep -i python as the prompt suggests
  • Resetting the server using sudo service octoprint restart as the prompt suggests
  • Running in safe mode, it did not do anything new or different

Have you tried running in safe mode?

  • Yes, the server does not run.

Did running in safe mode solve the problem?

  • No.

Systeminfo Bundle

  • There was no way for me to obtain it. After trying to run the ~/oprint/bin/octoprint systeminfo from the command line, I get the error "AttributeError: module 'click' has no attribute 'make_pass_decorator'"

Additional information about your setup

  • OctoPrint version: 1.7.2
  • OctoPi version: 0.18.0
  • Printer: Ender 3 v2

Here are the logs I was able to pull using WinSCP.

octoprint.log (255.6 KB)
plugin_pluginmanager_console.log (10.8 KB)
plugin_softwareupdate_console.log (73.4 KB)

From what I pulled from the logs, it looks like it's something with either OctoEverywhere or Octolapse. I tried using ~/oprint/bin/pip uninstall <plugin> according to this forum, but it draws the error "Warning: Skipping "OctoEverywhere"/"OctoLapse" as it is not installed". Maybe I am doing something wrong but I can't get it to work.

Any help would be appreciated. Thanks.

Sounds like a corrupted install, try How to reinstall OctoPrint

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.