Octoprint server won't start after upgrade to 1.3.10


#1

What is the problem?

Can't access OctoPrint after the upgrade finished successfully and the server rebooted. Attempting to access octopi.local results in a message saying OctoPrint server is currently not running

What did you already try to solve it?

  1. Restarting the RaspberryPi
  2. Logging into the server and trying to run /home/pi/oprint/bin/octoprint --host=127.0.0.1 --port=5000
  3. sudo service octoprint restart and sudo service octoprint start

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, octoprint.log, serial.log or output on terminal tab, ...)

Octoprint Version: 1.3.10
Octopi Version: Linux octopi 4.14.34-v7+ #1110 SMP Mon Apr 16 15:18:51 BST 2018 armv7l GNU/Linux
Printer: Prusa i3 MK3 with the latest firmware (3.5.0)

pi@octopi:~ $ cat ~/.octoprint/logs/octoprint.log
2018-12-10 03:00:23,713 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 03:00:23,721 - octoprint.server - INFO - --- Log roll over detected ---------------------------------------------------
2018-12-10 03:00:23,722 - octoprint.server - INFO - OctoPrint 1.3.9
2018-12-10 03:00:23,726 - octoprint.plugin.core - INFO - 18 plugin(s) registered with the system:
|  Action Command Prompt Support (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/action_command_prompt
|  Announcement Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/announcements
|  Core Wizard (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/corewizard
|  CuraEngine (<= 15.04) (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/cura
|  Discovery (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/discovery
| !Display ETA (1.0.2) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_eta
|  Logging (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/logging
|  OctoPi Support Plugin (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/octopi_support
|  OctoPrint Anywhere (0.9.5) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_anywhere
|  Plugin Manager (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/pluginmanager
|  PolarCloud (1.6) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_polarcloud
|  Print History Plugin (1.2) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_printhistory
|  Printer Safety Check (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/printer_safety_check
|  Slic3r (1.1.1) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_slic3r
|  Software Update (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/softwareupdate
|  Telegram Notifications (1.4.2) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_telegram
|  TouchUI (0.3.12) = /home/pi/oprint/local/lib/python2.7/site-packages/octoprint_touchui
|  Virtual Printer (bundled) = /home/pi/oprint/lib/python2.7/site-packages/octoprint/plugins/virtual_printer
2018-12-10 03:00:23,756 - octoprint.environment - INFO - Detected environment is Python 2.7.13 under Linux (linux2). Details:
|  hardware:
|    cores: 4
|    freq: 1200.0
|    ram: 918192128
|  os:
|    id: linux
|    platform: linux2
|  plugins:
|    octopi_support:
|      model: 3B
|      revision: a02082
|      version: 0.15.1
|  python:
|    pip: 9.0.3
|    version: 2.7.13
|    virtualenv: /home/pi/oprint
2018-12-10 03:00:23,756 - octoprint.server - INFO - ------------------------------------------------------------------------------
2018-12-10 03:15:23,715 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 03:30:23,718 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 03:45:23,720 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 04:00:23,723 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 04:15:23,726 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 04:30:23,728 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 04:45:23,730 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 05:00:23,733 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 05:15:23,736 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 05:30:23,739 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 05:45:23,741 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 06:00:23,744 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 06:15:23,746 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 06:30:23,748 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 06:45:23,751 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 07:00:23,754 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 07:15:23,756 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 07:30:23,758 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 07:45:23,760 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 08:00:23,762 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 08:15:23,764 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 08:30:23,766 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 08:45:23,770 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 09:00:23,773 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 09:15:23,776 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 09:30:23,779 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 09:45:23,782 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 10:00:23,785 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 10:15:23,788 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 10:30:23,791 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 10:45:23,793 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 11:00:23,795 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 11:15:23,797 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 11:30:23,800 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 11:45:23,802 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 12:00:23,805 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 12:15:23,807 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 12:30:23,810 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 12:45:23,811 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 13:00:23,813 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 13:15:23,815 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 13:30:23,818 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 13:45:23,820 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 14:00:23,822 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 14:15:23,824 - octoprint.server.heartbeat - INFO - Server heartbeat <3
2018-12-10 14:23:48,501 - octoprint.server.util.sockjs - INFO - Client connection closed: ::ffff:192.168.15.11
2018-12-10 14:23:51,131 - octoprint.server.util.sockjs - INFO - New connection from client: ::ffff:192.168.15.11
2018-12-10 14:23:54,700 - octoprint.plugins.announcements - INFO - Loaded channel _important from https://octoprint.org/feeds/important.xml in 2.3s
2018-12-10 14:23:56,596 - octoprint.plugins.announcements - INFO - Loaded channel _releases from https://octoprint.org/feeds/releases.xml in 1.5s
2018-12-10 14:23:58,163 - octoprint.plugins.announcements - INFO - Loaded channel _blog from https://octoprint.org/feeds/octoblog.xml in 1.4s
2018-12-10 14:23:59,942 - octoprint.plugins.announcements - INFO - Loaded channel _plugins from https://plugins.octoprint.org/feed.xml in 1.6s
2018-12-10 14:24:01,569 - octoprint.plugins.announcements - INFO - Loaded channel _octopi from https://octoprint.org/feeds/octopi.xml in 1.4s
2018-12-10 14:24:07,970 - octoprint.plugins.softwareupdate - INFO - Saved version cache to disk
2018-12-10 14:24:15,331 - octoprint.plugins.softwareupdate - INFO - Starting update of octoprint to 1.3.10...
pi@octopi:~ $

#2

What output did that produce?


#3

Hey, thank you so much for such a fast response!

No output, and I just found this oddball laying around, look:

(oprint) pi@octopi:~/oprint/bin $ ls -la
(...)
-rwxr-xr-x 1 pi pi       0 Dec 10 14:24 octoprint
(...)

Seems like octoprint executable has zero bytes. That may be the culprit here. Any idea how to fix it?

Thank you again!

Best,
Felipe


#4

No output at all? Not even an error? That sounds highly unusual.

Please provide the outputs of the following:

  • ps -ef | grep -i octoprint
  • df -h
  • cat /etc/octopi_version

I find it highly suspicious that the log cuts off before the "Installed successfully, rebooting" message, which makes me think of a disk space problem.

Any idea how to fix it?

Please do the other stuff first, I'd prefer to figure out what went wrong here. However, this should attempt to install the release again:

source ~/oprint/bin/activate
pip install https://get.octoprint.org/latest

#5

I find it highly suspicious that the log cuts off before the "Installed successfully, rebooting" message, which makes me think of a disk space problem.

Yes, that was my very first thought as well, but unfortunately that is not the case. Did you see that octoprint executable has zero bytes? That's super odd as well.

I will be glad to help you try to figure out what went wrong, so here it goes:

(oprint) pi@octopi:~/oprint/bin $ ps -ef | grep -i octoprint
pi        2391  1051  0 15:36 pts/0    00:00:00 grep --color=auto -i octoprint
(oprint) pi@octopi:~/oprint/bin $ df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        30G  4.0G   24G  15% /
devtmpfs        434M     0  434M   0% /dev
tmpfs           438M     0  438M   0% /dev/shm
tmpfs           438M   12M  427M   3% /run
tmpfs           5.0M  4.0K  5.0M   1% /run/lock
tmpfs           438M     0  438M   0% /sys/fs/cgroup
/dev/mmcblk0p1   43M   22M   21M  51% /boot
tmpfs            88M     0   88M   0% /run/user/1000
(oprint) pi@octopi:~/oprint/bin $ cat /etc/octopi_version
0.15.1

Please do the other stuff first, I'd prefer to figure out what went wrong here.

Sure thing. I won't reinstall it until you give me the green light.

Best,

Felipe.


#6

Yes, I saw that, combined with the cut off log that looked like disk space issues. But df -h indeed shows no such problems. What about dmesg, anything suspicious in there?

This really feels like file system hiccups.

Considering that octoprint.log got cut short I fear plugin_softwareupdate_console.log will also not be very helpful, but please share it just in case.


#7

Nothing helpful on dmesg either, and here goes plugin_softwareupdate_console.log:

2018-12-10 14:24:46,654 > Installing collected packages: sarge, OctoPrint
2018-12-10 14:24:46,655 > Found existing installation: sarge 0.1.4
2018-12-10 14:24:46,655 > Uninstalling sarge-0.1.4:
2018-12-10 14:24:46,656 > Successfully uninstalled sarge-0.1.4
2018-12-10 14:24:46,656 > Running setup.py install for sarge: started
2018-12-10 14:24:48,974 > Running setup.py install for sarge: finished with status 'done'
2018-12-10 14:24:48,975 > Found existing installation: OctoPrint 1.3.9
2018-12-10 14:24:50,191 > Uninstalling OctoPrint-1.3.9:
2018-12-10 14:24:50,192 > Successfully uninstalled OctoPrint-1.3.9
2018-12-10 14:24:50,193 > Running setup.py install for OctoPrint: started

Should I go ahead and reinstall?


#8

Huh... yeah, I think that's probably best. And maybe run a file system check. It cutting off like that really can't mean anything good, there should be a TON more output there, and if it isn't the disk space being used up, it might be the card slowly dying.


#9

for fun, also give us df -i.


#10

I will definitely check the integrity of the card. Thank you very much again for such fast support and for OctoPrint in general, I am very proud to be a patron in such a nice project!


#11

Here it goes:

Filesystem      Inodes IUsed   IFree IUse% Mounted on
/dev/root      1881152 66175 1814977    4% /
devtmpfs        110932   376  110556    1% /dev
tmpfs           112084     1  112083    1% /dev/shm
tmpfs           112084   444  111640    1% /run
tmpfs           112084     3  112081    1% /run/lock
tmpfs           112084    10  112074    1% /sys/fs/cgroup
/dev/mmcblk0p1       0     0       0     - /boot
tmpfs           112084    10  112074    1% /run/user/1000

#12

'k, so it isn't inodes either. It would have failed differently, but when I suspect disk space and it isn't, I usually check inodes.


#13

So reinstalling via pip didn't work, the octopi executable is still 0 bytes. Any other ideas?


#14

Not really, other than the aforementioned file system check. Could you share the output that got produced while attempting to reinstall?


#15

Everything was already installed so it basically didn't do anything:

pi@octopi:~ $ source ~/oprint/bin/activate
(oprint) pi@octopi:~ $ pip install https://get.octoprint.org/latest
Looking in indexes: https://pypi.org/simple, https://www.piwheels.org/simple
Collecting https://get.octoprint.org/latest
  Downloading https://get.octoprint.org/latest (5.3MB)
    100% |████████████████████████████████| 5.4MB 1.3MB/s
Requirement already satisfied (use --upgrade to upgrade): OctoPrint==1.3.10 from https://get.octoprint.org/latest in ./oprint/lib/python2.7/site-packages
Requirement already satisfied: flask<0.11,>=0.10.1 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.10.1)
Requirement already satisfied: Jinja2<2.9,>=2.8.1 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2.8.1)
Requirement already satisfied: regex!=2018.11.6 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2018.2.21)
Requirement already satisfied: werkzeug<0.9,>=0.8.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.8.3)
Requirement already satisfied: tornado==4.5.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (4.5.3)
Requirement already satisfied: PyYAML<3.11,>=3.10 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (3.10)
Requirement already satisfied: Flask-Login<0.3,>=0.2.11 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.2.11)
Requirement already satisfied: Flask-Principal<0.4,>=0.3.5 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.3.5)
Requirement already satisfied: Flask-Babel<0.10,>=0.9 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.9)
Requirement already satisfied: Flask-Assets<0.11,>=0.10 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.10)
Requirement already satisfied: markdown<2.7,>=2.6.9 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2.6.11)
Requirement already satisfied: pyserial<3.5,>=3.4 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (3.4)
Requirement already satisfied: netaddr<0.8,>=0.7.19 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.7.19)
Requirement already satisfied: watchdog<0.9,>=0.8.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.8.3)
Requirement already satisfied: sarge==0.1.5post0 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.1.5.post0)
Requirement already satisfied: netifaces<0.11,>=0.10.6 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.10.7)
Requirement already satisfied: pylru<1.1,>=1.0.9 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.0.9)
Requirement already satisfied: rsa<3.3,>=3.2.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (3.2.3)
Requirement already satisfied: pkginfo<1.5,>=1.4.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.4.2)
Requirement already satisfied: requests<3,>=2.18.4 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2.18.4)
Requirement already satisfied: semantic_version<2.5,>=2.4.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2.4.2)
Requirement already satisfied: psutil<5.5,>=5.4.6 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (5.4.6)
Requirement already satisfied: Click<6.3,>=6.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (6.2)
Requirement already satisfied: awesome-slugify<1.7,>=1.6.5 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.6.5)
Requirement already satisfied: feedparser<5.3,>=5.2.1 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (5.2.1)
Requirement already satisfied: chainmap<1.1,>=1.0.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.0.2)
Requirement already satisfied: future<0.16,>=0.15.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.15.2)
Requirement already satisfied: scandir<1.4,>=1.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.3)
Requirement already satisfied: websocket-client<0.41,>=0.40.0 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.40.0)
Requirement already satisfied: python-dateutil<2.7,>=2.6.1 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (2.6.1)
Requirement already satisfied: wrapt<1.11,>=1.10.11 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.10.11)
Requirement already satisfied: futures<3.2,>=3.1.1 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (3.1.1)
Requirement already satisfied: emoji<0.5,>=0.4.5 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (0.4.5)
Requirement already satisfied: monotonic<1.4,>=1.3 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.3)
Requirement already satisfied: frozendict<1.3,>=1.2 in ./oprint/lib/python2.7/site-packages (from OctoPrint==1.3.10) (1.2)
Requirement already satisfied: itsdangerous>=0.21 in ./oprint/lib/python2.7/site-packages (from flask<0.11,>=0.10.1->OctoPrint==1.3.10) (0.24)
Requirement already satisfied: MarkupSafe in ./oprint/lib/python2.7/site-packages (from Jinja2<2.9,>=2.8.1->OctoPrint==1.3.10) (1.0)
Requirement already satisfied: singledispatch in ./oprint/lib/python2.7/site-packages (from tornado==4.5.3->OctoPrint==1.3.10) (3.4.0.3)
Requirement already satisfied: certifi in ./oprint/lib/python2.7/site-packages (from tornado==4.5.3->OctoPrint==1.3.10) (2018.4.16)
Requirement already satisfied: backports-abc>=0.4 in ./oprint/lib/python2.7/site-packages (from tornado==4.5.3->OctoPrint==1.3.10) (0.5)
Requirement already satisfied: blinker in ./oprint/lib/python2.7/site-packages (from Flask-Principal<0.4,>=0.3.5->OctoPrint==1.3.10) (1.4)
Requirement already satisfied: Babel>=1.0 in ./oprint/lib/python2.7/site-packages (from Flask-Babel<0.10,>=0.9->OctoPrint==1.3.10) (2.5.3)
Requirement already satisfied: speaklater>=1.2 in ./oprint/lib/python2.7/site-packages (from Flask-Babel<0.10,>=0.9->OctoPrint==1.3.10) (1.3)
Requirement already satisfied: webassets>=0.10 in ./oprint/lib/python2.7/site-packages (from Flask-Assets<0.11,>=0.10->OctoPrint==1.3.10) (0.12.1)
Requirement already satisfied: argh>=0.24.1 in ./oprint/lib/python2.7/site-packages (from watchdog<0.9,>=0.8.3->OctoPrint==1.3.10) (0.26.2)
Requirement already satisfied: pathtools>=0.1.1 in ./oprint/lib/python2.7/site-packages (from watchdog<0.9,>=0.8.3->OctoPrint==1.3.10) (0.1.2)
Requirement already satisfied: pyasn1>=0.1.3 in ./oprint/lib/python2.7/site-packages (from rsa<3.3,>=3.2.3->OctoPrint==1.3.10) (0.4.2)
Requirement already satisfied: urllib3<1.23,>=1.21.1 in ./oprint/lib/python2.7/site-packages (from requests<3,>=2.18.4->OctoPrint==1.3.10) (1.22)
Requirement already satisfied: idna<2.7,>=2.5 in ./oprint/lib/python2.7/site-packages (from requests<3,>=2.18.4->OctoPrint==1.3.10) (2.6)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in ./oprint/lib/python2.7/site-packages (from requests<3,>=2.18.4->OctoPrint==1.3.10) (3.0.4)
Requirement already satisfied: Unidecode<0.05,>=0.04.14 in ./oprint/lib/python2.7/site-packages (from awesome-slugify<1.7,>=1.6.5->OctoPrint==1.3.10) (0.4.21)
Requirement already satisfied: six in ./oprint/lib/python2.7/site-packages (from websocket-client<0.41,>=0.40.0->OctoPrint==1.3.10) (1.11.0)
Requirement already satisfied: pytz>=0a in ./oprint/lib/python2.7/site-packages (from Babel>=1.0->Flask-Babel<0.10,>=0.9->OctoPrint==1.3.10) (2018.4)
Building wheels for collected packages: OctoPrint
  Running setup.py bdist_wheel for OctoPrint ... done
  Stored in directory: /tmp/pip-ephem-wheel-cache-6GIZcP/wheels/2e/0d/09/39f09d58d37b3c4977631d1a6c08c6c66c893b6c7eac42e3dc
Successfully built OctoPrint

#16

Trying to force-reinstall now.


#17

Oh, wait, try pip install --force-reinstall https://get.octoprint.org/latest. Maybe that will tickle it into action a bit more.

edit :joy:


Octoprint on pi3 upgrade problem
#18

We are back in business. No errors from running it from the command line, and sudo service octoprint start also worked:

So once again thank you very much @foosel and @tedder42 for your help.

Have a great day, both of you!


#19

Still, keep an extra eye on that SD card, and maybe make a backup via the new bundled plugin just in case :wink:


#20

Definitely! Will do that right now.