OctoPrint undervoltage 3.5tft yes I've searched

What is the problem?

Ocotprint regularly has under voltage warnings along with random ui restarts

What did you already try to solve it?

Multiple new PSU, Official Raspberry Pi power supplies as well as two new canakit psu.
I've also tried only running it with barebones as well as plugging one peripheral in at a time to see if it was the screen or perhaps the printer, or even the c270 web camera. But it does the undervoltage no matter what is or isn't plugged in.

I also have a USB power meter that is showing the canankit psu at 5.15Volts nominally, witha .85amp draw. Every other power supply only gets asked for around .5amp.

Have you tried running in safe mode?

Yes same issue.

Did running in safe mode solve the problem?

Negative Ghost Rider

Complete Logs

octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support! Not log excerpts, complete logs.)


Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible


Hello @Papa_G

Can you also share these informations:

Ok, take your time...

Do you have a PS the rates way more the 3A, so about 5A?

And do you have another Pi to compare?

All of the PSU's that I've purchased, based off of the octoprints recommendation's(5 of them in the past week) are rated at 5v 2.5amps. So you think I need to go big or go home. In other words more amps. Looking at this frankenstein setup someone on here has setup, Octopi power supply vs. Undervoltage.....but once again, that's a lot more work than I want to devote to this as it has already been a triple struggle threat with these things. I don't even remember what my end goal was. Was it lights or ease of pritning or monitoring....geez it all seems extraneous now for the amount of effort...

I have two more Pi's to compare with. Shall I just boot up from the SD card in the Pi I'm having issues with?

So I guess that would a be a no off hand considering I am looking at multiple fast chargers that list 5v 5amps but none of them get asked for that kind of power from the Pi so they are only giving it .85amps max.

may have to upgrade to Pi4's....silly cause these are a week old...

Please no chargers. They work different than a regular power supply. They often can't compensate drops in the mains and are not able to deliver power at a peak situation.

1 Like

Except that it's not OctoPrint that is detecting an issue here, it's your Raspberry Pi itself and OctoPrint is just repeating its message to you. So you just shot the messenger. But considering that lovely attitude you have on display here, I can't say that I'm sad to see you go.


Semantics. Charger is just a term. I have actual power supplies from the raspberry pi foundation. Unless someone has a better recommendation.

As far as the attitude goes. Shooting the messenger would be me telling you to go get stuffed. Stating that octoprint can go get stuffed is just a expression of my frustration.

I do appreciate any help that is being presented.

So in reading the above again and searching the web for 5v 5amp regulated micro usb psu...not finding a lot. Any suggestions?

Lots of 5v 2.5amp. Lots of fast chargers, but very few if any regulated PSU's.

Really what's confusing is the Pi isn't even pulling more than an amp (.85 max during bootup, sits around .5 otherwise, according to my USB meter) and I'm getting UV warnings. Maybe its in need of a reinstall. tft screen and webcam, not a lot of gear.

No, it's a technology.

You may never forget the peak consumption the Pi can take.
And if the Pi complains of not enough, there is an issue. Maybe a bad USB connector.

Either way you want to define it, technology or words used to describe an item, neither the chargers nor the PSU's from RPi foundation are stable enough to not give me a UV warning. If it is a USB port issue, it wont matter how many supplies I throw at it. Also I'm taking a stab here but I'm guessing you meant "You may never know what the peak consumption the Pi can take."

That being said, I have some adjustable buck converters on the way and will just make my own for future use. Will also try my bench power and see if this thing will not UV with more amps. Probably a wonky RPi.

Thanks anyway. and FTOG.

There's lots of places that voltage drop can occur, in the USB connector, the regulator and the power circuit itself. IIRC under normal operation this is ~0.2V, which is why the official power supplies are rated 5.1V, so that there is plenty of capacity.

The magic number here is about 4.65V, below roughly here the Pi will begin to complain. From looking at the logs you have posted above, it doesn't seem to be a persistent issue, only occasionally complaining of active throttle state. The relevant command is vcgencmd get_throttled, which will return the state. 0x0 is nothing, 0x50000 where the first bit indicates a problem.

Very occasionally can this circuit be faulty, I've not seen it happen but some people say it can. It is more likely that power supplies are not up to spec, or there is some sort of voltage drop somewhere. One thing you could do, is measure the voltage across the GPIO pins (5V - GND), and see what it says. I believe this is kind of 'the other side' of the Pi's power circuits, after all the regulators and the peripherals have sucked their power, this is the other end - you get what's left on the GPIO pins.


Holy shit. Thank you for the info.

Perfect. Info. Baseline. Reference. And actions. Stand by while I get it out again and start it cooking.

Also, this is a preemptive strike as it has not failed during any actions, but it keeps blanking the screen and I am concerned 36 hours into a 37 hour job it could fail.

And with the above info on intermittency and watching the meter as the Pi does its thing, the voltage has not dropped below 4.9v since I've started logging it.

1 Like

Maybe next time, before you vent your frustration about having issues with an open source project that is provided to you completely free of charge, and with a strong support community to boot, you should remember that there are people who spend a lot of time and effort on said project and how this kind of venting frustration will be perceived by them.

Being frustrated is all fine and dandy. I can tell you that running an open source project like OctoPrint, for years, is often an utterly frustrating experience. But venting said frustration at people is not going to solve your problems. Quite the contrary actually as you alienate the people most likely to be able to help you in the process. Stay friendly, vent in private, remember the human on the other side. These times are taxing enough as they are on all of us.


You are absolutely correct on those points. Which is why I guess Repetier Server is currently running my prints as I cannot rely on the Octoprint hardware at the moment. And had I actually stopped and logically ran it through my head, I would have never ended up here. It is obviously hardware related, not a software issue. And lastly, there are sensitive folks out there now a days that can't process anyone's guff least of which mine, reading the room has never been and will never be my strong suit, my apologies.


Is your PI in an enclosed case?
I have one pi that when used with a camera throws this error when the case is closed yet if I take the top off and it "breathes" better does not error.
Never got an over temp alarm, happened regardless of power supply I used -- and I used the same PS from another PI with same camera and that pi even has an LCD (failing one did not).