OctoPrint Update from 1.10.0 to 1.10.1 or 1.10.2 Fails

I have been unable to install either update from 1.10.0 to 10.1 or 10.2. In every case it gives me a warning popup that states "Update failed!" and tells me what logs to consult:

I looked at the logs, and the error message in the installation window, but couldn't decipher what the actual error was.

Some things to note:
I no longer use OctoPrint to manage the actual print loading and gcode loading. I use PrusaSlicer 2.7.4 to talk to my Prusa MK4. I still make use of the camera monitoring, though. The only reason I stopped using OctoPrint is that the PrusaSlicer seems to give me better control of the actual print functions. I'm completely fed up with the PrusaConnect application, and just wish that I could use OctoPrint for everything.

Also, you should be aware that I'm using the OctoPrint Raspberry Pi as an MQTT broker as well. I don't know if this is the source of the issue.

What did you already try to solve it?

I have tried updating with the printer off and on, while printing and between prints. No luck.

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No. I'm still unable to install the update.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

I've included the System Information bundle.

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

OctoPrint 1.10.0
Python 3.7.3
OctoPi* 0.18.0 (build 2022.05.24.101555)

Windows 11 Pro, Firefox browser
Octoprint v 1.10.2 install error.zip (1.6 KB)
octoprint-logs.zip (987.6 KB)
octoprint-systeminfo-20240625212827.zip (160.8 KB)

Have you read these?

The links are mentioned in the error logs.

There is also this:

octoprint.plugins.softwareupdate.exceptions.UpdateError: Error while executing pip install

Check the PIP and install it manually.

Thank you for the reply. Can you point me to instructions for checking the PIP and installing it manually?

You have to enter OctoPi via SSH with the help of e.g. Putty.

I installed the latest PIP using the instructions shown via SSH. I still can't install the update.
I copied the error message shown in the update processing window:
Octoprint v 1.10.2 install error.zip (1.6 KB)
I'm not familiar enough with Linux scripting to be able to interpret the results. However, it seems to me that at the beginning of the process it is trying to download the update as a zip file from the GitHub archive, and it runs into some kind of error exception. Is there something interrupting the download of the zip file? Are there errors in the processing script?

For some reason your system can't reach the GitHub server where the update zip is located. Do you happen to run a network wide ad blocker perhaps that for some reason blocks all of codeload.github.com? That could explain why.

If push comes to shove you can circumvent that by fetching the update from PyPI instead, in that case

~/oprint/bin/pip install OctoPrint==1.10.2

via SSH followed by a server restart should get you updated, but you will need to do that manually on each update, so you should really rather investigate what is causing your Pi to not be able to connect to codeload.github.com.

It seems you are correct. I disabled Adblock and MalwareBytes and was then able to install the update. Curiously, neither of these provided their usual indication that they had blocked a connection, so I don't really know what was happening. In any case, all is up to date now! Thank you for your help!

1 Like