OctoPrint Update Not Started

Running 1.5.2, when trying to update plug ins and ocroprint I'm havinfg the error written below:

"Update not started!
The update could not be started. Is it already active? Please consult [octoprint.log]."

I have checked the log but couldn't understand where the problem is, I have tried the it in the safe mode but nothing changed.

I have uploaded my log in the link below:

I will be glad if someone can help me

Your Raspberry Pi is reporting undervoltage errors: throttle_state: '0x50005' (Line 46 in log).

You probably need a better power supply, for your Pi this should be 5V 2.4A.

Pi Undervoltage/power issues: I had a strange lightning bolt/temperature symbol with an exclamation mark popup in my navbar, what does that mean? - I'm not sure if you are seeing the icon, but the logs definitely report the issue.

1 Like

Thanks I will chech with a different power supply and cable :slight_smile:

1 Like

Hello, I'm encountering the same issue. In my logfile it says:

| model: Raspberry Pi 3 Model B Rev 1.2
| octopi_version: 0.18.0
| throttle_state: '0x50005'

I have tried 3 different power supplies, 2 of them rated with 3A.

Any hints how I can fix this issue?


They may be rated 3A, but if the voltage is too low then you will still have an undervoltage system.

Key things to look for in a power supply:

  1. It is a power supply. Seems obvious, but a phone charger is not a power supply, as they often cannot provide constant power. Your phone will not care, the RPi does,
  2. The cable and connections are high quality, it has a thick enough cable (nothing extreme, just not super tiny)
  3. It outputs ~5.1V - there is always some voltage drop between the PSU and the internals of the Pi, just physics, so having a 5.1V or 5.2V supply is better.

Hello, I'm encountering the same issue. In my logfile it says:

2021-04-03 14:51:54,911 - tornado.access - WARNING - 409 POST /plugin/softwareupdate/update


Hello @Milan_Ratveisky !

Could you please share a complete octoprint.log?

1 Like

octoprint.log (31.3 KB)

!!! UNDERVOLTAGE REPORTED !!! Make sure that the power supply and power cable are capable of supplying enough voltage and current to your Pi.

You also got an undervoltage issue
Check out @Charlie_Powell s post above :slight_smile:
You could also check if the problem still persists when you disconnect all connected usb devices (including the printer).

1 Like

I dropped there RPI 4 with originalal resources and everything is OK


1 Like

I have been plagued by this, unplugged the USB's and changed the power supply even bought a USB power monitor to see what's drawing what.
In the end, it came down to the simple fact I had a Fan plugged into the GPIO board. Unplugged that and updates work fine. plug fan back in after update. no need to unplug the USB either.

If the Pi again runs in the undervoltage condition, nothing is won. You may get trouble else where. Consider to connect the fan not to the GPIO.

that's the issue. its not reporting under voltage. its only showing the update not started error when doign updates. The PI runs perfectly fine.

i have had the same PI with the same setup for 2 years. only since 1.5 has there been these issues for me.

Please upload the octoprint.log and we will see what it says.

I have the exact same issue. No undervoltage though.
octoprint.log (139.7 KB)

I attached the log. Any ideas or thoughts?

By the way: I really LOVE OctoPrint.

Indeed you have an undervoltage and a throttling issue:

|  plugins:
|      pi_support:
|          model: Raspberry Pi 3 Model B Plus Rev 1.3
|          octopi_version: 0.17.0
|          throttle_state: '0x50005'

Aio, thanks. I looked for under voltage but couldn’t find it. I will dig further and change power. I will let you know if I got it to work.

1 Like