OctoPrint (Windows) won't start - "Port 5000 already in use"

What is the problem?

Octoprint installed on Win10 system wouldn't start. Gives message that Port 5000 is already in use, even after cold reboot.

What did you already try to solve it?

Used NETSTAT to see if 5000 was active - it wasn't listed.
Deleted Octoprint folder and tried to reinstall from scratch.
Installer won't allow port 5000, reporting port already in use.
Used Process Explorer to search for "5000"; found PID1644 referring to that number.
Used TASKLIST and TASKKILL in SAFE mode to terminate PID 1644 and rebooted.
Attempted to reinstall Octoprint. Still got the message that port 5000 was already in use.
No reference to "5000" could be found in Process Explorer nor NETSTAT
TCPView does not list port 5000 in any of its processes.
Checked firewall for any blocks on 5000; OctoPrint allowed on 5000
(Zoom also allowed on 5000 - Uninstalled Zoom; no effect.)

Have you tried running in safe mode?


Did running in safe mode solve the problem?

No. Attempting to run the installer still returned the error "Port 5000 is already in use"

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)
Not available. Can't start Octoprint. Can it be extracted from the folder? Which file(s)?

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Octoprint version: Originally 1.9.0. Attempting to install 1.9.1
OS Win 10 Pro 22H2
Printer: Ender 3S1 (Not active at time of attempted reinstallation.)
Browser: Firefox

Since port 5000 can't be 'seen' by any of these tools, how can I figure out what is keeping it open?

For clarification: You installed OctoPrint on your Windows PC?
If yes: Did you use a certain tool/script?

What URL did you use to connect OctoPrint?

This is a bit contradictory:


How can you run OctoPrint in safe mode when you can't reach it?

Assuming you used my installer, there are registry settings that the installer adds for previously entered port numbers. You can delete that registry or use windows App settings to uninstall OctoPrint. The version you have installed though is older and may not completely remove those from the registry. To verify open regedit in windows and delete the HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\OctoPrint\Instances key and run the installer again.

the newer version now has a new Upgrade OctoPrint item that gets added to the start menu, so when you get the update notice in the future you should be able to use that from the start menu to upgrade.

I tried to run it in Safe Mode for Win10 -
Wasn't aware that OctoPrint had a safe mode

1 Like

That appears to have worked. Thank you very much!

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.