Octoprint with new SKR Mini E3 v2.0 and TFT3.5 v3.0

Upgraded my ender 3 pro with SKR Mini E3 V2.0 and a TFT3.5 V3.0, and now Octoprint can't control printer. I've looked a few places and I see that I'm not the only one with this issue. Has anyone gotten this configuration to work yet?

1 Like

I need help with this too! I have the Ender 3 Pro V2, with the newest motherboard. Octoprint was working before Marlin 2.0 update and now it isn't working at all. I keep getting serial port errors.

I am having the same issue.

I have the same problem too.
I've tried an other rpi, usb cable, the newest marlin 2.0.6 and a clean version of octopi without plugins and updates.
Nothing worked.
In the log i could see timeouts because octopi doesn't receives oks.
I tried in marlin advanced oks and a bigger buffer.
At least I modified an usb cable and cut of the red v+.
Nothing helps.
Printing with pronterface or from sd cart works fine.
Have somebody any suggestions?

Enable serial.log (<- click), reproduce the issue (Try connecting) and post it here, maybe someone will be kind enough to take a look and point you to where things have gone wrong.

I tried the solution from this topic and it worked for me. I've printed a 1.5h print without any stops, freezes or other issues. The v2 has the same port settings as the 1.2 board.

1 Like

The BL Touch firmware Configuration.h has those settings already at default.

I have the SKR Mini E3 V2.0 and still have the issue of Octoprint not connecting. Even tried going through the USB port on the TFT, didn't work.


Load Out: BTT SKR Mini E3 V.2 w/ TFT35-E3 V3.0

Original Problem: Latest version of Octoprint as of 22SEPT2020 installed on a Pi4B(2GB) would not, no matter the Configuration.h settings (including redefining SERIAL_PORT), no matter the combo of power cycling and USB in, out, or in a USB3.0/USB2.0 slot... Nothing worked.

Solution: USB cable from Pi4 to SKR Mini... cut/disable the 5v power in the cable. Cut the RED wire inside the USB cable. INSTANTLY I had the two boards communicating freely back and forth.

I also had this problem with Creality 3D V1.1.4 board, and the same solution worked on it as well.

Hi all, I've got the same issue.
dietpi on odroid c1, octoprint works but can't find the printer.
I try with usb cable without 5v (red wire cut) too, but nothing happen.
I try with repetier server and same issue. I think it's big tree tech firmware issue (I took the last this night to try and always same issue).
The odroid found the printer with lsusb (return a stm32 boot loader code). but seems to not link any tty to it.

I am having this same issue today, was there any resolution? I tried cutting the red wire but no luck. Printer works but man i miss octoprint

I have the SKR mini E3 v2.0 and the TFT35-E3 V3.0. I use Marlin main branch No BLTouch. Using a Raspberry Pi4B and Octoprint Version 1.4.2. I always make sure my libraries on linux are up to date by having a crontab (sudo) setup:

0 22 * * 0 sudo apt-get update -y && sudo apt-get upgrade -y && sudo apt-get autoremove -y && sudo apt-get autoclean -y > /home/pi/crontab.log 2>/home/pi/corontab.err

I have connected the TFT to the EKR mini with both the display cable and the serial cable so I can switch between Touch screen mode and old fashioned LCD mode.

I have connected my Pi4B to the SKR mini E3 mini USB input via a cable where I used tape to mask the 5V (so I did not cut the cable, but masked it).

Everything works like a charm from the start. No issues. I do have the baud rate fixed to 115200. Higher baud rates gave me issues (configuration.h).

To be honest, I actually use the LCD mode the most while printing.

Be careful with the pi updating itself or doing manually, my installation borked itself and wouldn't connect via USB anymore to my printer (SKR Mini E3 V2). Seen a post since about how to reinstall the USB driver/port, but I did a backup, re-image with latest image (64-bit RPI4) and restore and worked perfectly since.

What solved it for me was unchecking "Request exclusive access to the serial port" in the OctoPrint settings menu.

Thanks for sharing

cant access octoprint, how i supposed to get to settings???

If you can't access OctoPrint at all, I think you have bigger problems than it not connecting to the printer, and should probably fix that first.

1 Like

Not true. Octoprint worked fine with my 8bit melzi board . I install a 32bit SKR mini e3 v2 and now it will not connect. The SKR board is working great. i have taped off the +5 pin in the usb cord. Tried an ether net connection. Nothing works. If it dont work with octoprint I'll put the 8bit board back . Damn shame