OctoPrint wont connect, no serials

What is the problem?

OctoPrint wont connect to printer - no serial connections found

What did you already try to solve it?

Restarting OctoPrint, shutting down OctoPrint and unplugging, turning printer on first and then OctoPrint, ls /dev/tty* doesn't list any USB serials, covered the power pin on the USB cable with tape and plugged back in to make sure there was no back power issues, tried multiple cables

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!)

octoprint-systeminfo-20211009052522.zip (31.2 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

Creality Ender 3 V2 running 32bit 4.2.2 board, running jyers 1.3.5b firmware for bltouch, browser is Chrome, Windows 10, Raspberry Pi 3B+, OctoPrint v1.6.1, OctoPi 0.18.0

Hello @Caleb_Kopitzke !

Have you tried to connect the printer to the PC running pronterface?

For it is a Creality printer, you may try with or without a SD card in the printer's slot.

You also may have a look on this thread:

and this:

and this:

I have faced with the same issues you have faced. I have tried roles, permissions, user changes, all ls commands but never got progress.

It is related to the cable you have. Please try wtih an another USB cable. Phone USBs does not work wometimes. I have found an old USB cable and tried. Recognizes on the first time.

1 Like

Unmounting the SD card from the printer was the fix...

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.