OctoText on TrueNas Jail

What is the problem?

Hey all, I'm having a lot of trouble trying to get OctoText SMTP settings to work on OctoPrint running inside a jail on a TrueNAS server. I used this amazing guide to set up the octoprint server and it works flawlessly, however when trying to use the OctoText plugin it doesn't want to cooperate.

What did you already try to solve it?

I tried making both gmail and outlook accounts, I tested using SMTP Test Tool and both accounts worked using TLS, google also worked using SSL with respective ports. I also tried using the "app passwords" for google multifactor authentication accounts, which worked in gmass testing but not for OctoText.

I also tried to telnet to smtp.google.com from the shell of the TrueNAS jail and it let me do it so I'm assuming that connectivity isn't the issue.

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle

octoprint-systeminfo-20230706002549 (2).zip (19.2 KB)

Additional information about your setup

TrueNAS jail setup!