Official RPI 7” touch screen

What is the problem?

What did you already try to solve it?

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, what kind of hardware precisely, ...)

  1. My problem- Hello, I cannot get my 7” official RPI touch screen to work after I install Octoprint and reboot. I can print from my computer to the raspberry pi 3B + through my local network, but my touch screen will not work. I have tried rebooting, and choosing the boot option to boot in the desktop. Even after that, my screen is black, and only has a little white hyphen(-) in the top left corner. I have tried following YouTube videos, and other forums I could find. I installed everything, checked everything, I am lost. I am very new to this kind of stuff, so if you do decide to help me please keep it simple. Thanks

Try to get it to work without OctoPrint at all.

  • Having connected it to your Pi, does anything show up on the display during bootup? You should see console messages; no extra drivers should be necessary for the official 7" Raspberry Pi Foundation display.
  • If you imaged from the OctoPi iMG file then it doesn't include "the Desktop" so you're leaving out some steps here. Did you go into sudo raspi-config and do anything?
  • From this page, it looks like the official screen is connected via a ribbon cable to the Pi. Obviously, both ends of the cable could potentially be flipped over accidentally which gives 1-in-4 chances of randomly plugging it in correctly. It looks like there are four wires which attach to GPIO pins. I'm guessing that this is for the input device from the TFT.
  • There are two ribbon cable connectors on the Pi: one is for the camera and one is for the display device. You'd want to make sure that you're in the correct one.
  • You definitely want to start with the raspi-config option to boot automatically as pi into the Console (not the Desktop).
  • From the Raspberry Pi forum's troubleshooting section, I see that SPI might need to be turned on.

After I completed everything on that list. Everything worked except my touch screen.if I logged into Octoprint, I could print from my computer through my pi. I tried hooking an HDMI cable to one of my computer monitors, nothing. Even in the control tab on my computer, my camera is working. I reflashed my SD, and followed this guy.

The exact same thing happened again. I have logged in to the raspi, and configured it to boot to desktop. Then reboot, same black screen. I went and got another SD card today, and downloaded AstroPrint. I paid for it. Everything works now except my cam, and it is an official RPI cam. I have another complete set, so I built it, and tried to load OCTO print again onto a different raspberry pi 3B plus, and different screen, and the same thing happened. I am at a loss. No matter what I do I am having problems. I am sure it is me, Computers are not my strong suit, but I am very persistent, and have tried multiple times, triple checking everything, and no luck

I've installed OctoPrint + TFT images all the time. I've written reviews like this one and here. I've written code for Robo 3D and OneClickMetal for their display interfaces on their printers.

I note that it helps when you purchase from Adafruit or a vendor like Although the 7" Raspberry Pi display is official, it feels to me like their page for it is sorely lacking in information, as compared to the typical Adafruit write-up.

There are four parts to a TFT setup.

  • The console part of the display
  • The console part of the TFT input device
  • The x11 part of the display
  • The x11 part of the TFT input device

So know that any instructions which deal with a path which includes x11 in it is dealing with the x11 windows desktop for Raspbian, the GUI part of it. Anything which loads a driver in the /boot/config.txt file is for the GUI-less part of Raspbian.

Keep reading. Keep following reviews and tutorials.

Thank you for your help, I will keep reading and learning as I go. I am super new to this, but it is really rewarding to find answers and figured this stuff out. Thanks again for taking the time to help.