Offline (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @

What is the problem?
After it starts printing, octoprint stops with the error : Offline (Error: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @
What did you already try to solve it?
Replaced USB cable and purchased a new Power Supply for my Pi.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
serial.log (148 Bytes) octoprint(1).log (1.7 MB)
Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)


The snappy web interface for your 3D printer

Version 1.3.12

About OctoPi

The ready-to-go Raspberry Pi image with OctoPrint

Version 0.16.0, running on Raspberry Pi 3 Model B Plus Rev 1.3

Wifi Duet Board
Power Supply 5v 2500ma
Replaced USB cables

5 Inch Touchscreen with HDMI and USB

1 Like

Hi @Archie_Karagiannis!

I'm sorry, but you have to activate something.
Your serial.log reads:
2019-11-22 10:05:39,998 - serial.log is currently not enabled, you can enable it via Settings > Serial Connection > Log communication to serial.log

octoprint.log looks like you might be in the habit of just powering it off without proper shutdown, which also explains some of the log file corruption going on in there. If that is indeed the case: don't do that. ALWAYS shut down your Pi properly any wait for it to no longer flash LEDs before pulling power.

Apart from that: What @Ewald_Ikemann said

Thanks for your replies
Ok I have tried again and here are the updated logs.
This time i removed the 5' screen off the pi and ran it on its own ...

Still no luck
Please check the logs ...

serial(1).log (945.8 KB) octoprint(2).log (1.9 MB)

Sorry again, the logs are not parallel in time. The serial.log starts (2019-11-23 04:03:46,707) when the octoprint.log has already ended (2019-11-22 10:11:19,557).
Please look if there is a octoprint.log that matches the serial log.

2019-11-23 04:52:35,538 - Unexpected error while reading serial port, please consult octoprint.log for details: SerialException: 'device reports readiness to read but returned no data (device disconnected or multiple access on port?)' @

23112019_octoprint.log (49.3 KB) serial(1).log (945.8 KB)

Ok Lets try these ..

Thank you! What is connected to the Pi: the printer, the touchscreen. Something else?
Do you have another program on the Pi that wants to connect to the printer?

Hi Ewald, I just have it connected to my Wifi Duet board and a Webcam.

ok i tried something new.

I purchased and Ankler USB to my printer and a official Power supply.

Still have the same issue.

attached are the latest logs ..

Please Help

serial.log (533.9 KB) octoprint(4).log (408.5 KB)

One shot into the dark: maybe it's a heat problem.
Either the USB chip on the Pi gets too warm and fails or by the heat of the entire board a solder point of the USB chip gets unconnected.
You may put a heat sink onto the USB chip or try another RPi board.

If you're running Anywhere, disable that and try again.

Ok i removed the USB Webcam and it worked.

Could it be a faulty webcam or the usb port ??

Could be the overall usb power consumption.
You could try this with your printers usb cable Put tape on the 5V pin - Why and how

1 Like

I'm having this same issue with 2 rp3+ running the latest octopi and there is a post on #octoprint that is about this as well.

Is this a bug?


Hello @pbbft!

Could you please open a new thread and fill in the template. LOGS are most important.

And check the FAQ for god's sake, that has a lengthy article on this exact message and what it means and why OctoPrint cannot do anything about it:

After much experimenting, I replaced the webcam with a logitech C270 and removed Anywhere.
This seems to have solved the issue .
Also i might add i upgraded to the latest firmware on my wifiduet

1 Like