Pi 3 model B unable to connect to WIFI

In response, yes. I was editing that file, and the screen shot in my post is of that portion of the file I edited. I have confirmed that my Raspberry can “see” my WIFI router (ATT Wireless) but dont know how to confirm that my raspberry is sending a handshake, or i there is another issue.

1 Like

One more question, is it a RPi3B or an RPi3B+?

My OctoPi (0.14.0, Jessie) on a RPi3B is connected via WiFi and attached to my 3D printer. I have an RPi3B+ with OctoPi 0.15.1 connected to my WiFi (but no printer). Both were successful connecting to WiFi on initial boot.

Do you have a monitor connected to the RPi? If not, how did you manage to get the sudo iwlist wlan0 scan output? Did you check the output of dmesg for clues?

You might have better luck looking / asking in the official RPi forums.

There are other threads in this Discourse on problems with WiFi connections but I don't know if any of them have any better suggestions.

mine is a B +

I had it connected to a monitor and a keyboard which is how i was able to look up the IP on eth0.

I never ran that other command (sudo iwlist wlan0) I'll try that tonight and see if it can tell me anything else I couldn't find otherwise.

Is there a easy to follow walkthrough on how to install Octoprint on top of raspbian (with the GUI)? I can get raspbian up no problem, but some of the commands in the walkthrough on github were confusing.

Maybe I'll try and spin through them again tonight and try with a fresh set of eyes!

To be clear, there are two of us with the same issue. For me, the boot partition was the only one visible. To answer a q that came up earlier, I had hooked the pi to a tv to see if it could see my router... Short answer is that it could see th3e router.
Today, after continuing to have problems we reflashed to octopi .13 We were able to log into another wifi network, but when I amended the txt file for the home router... No joy.

Yea sorry to jump on your thread here as well, but it seems like we are having identical problems!!! Since you started the post, I'll just sit back and let you take over answering the questions! Hopefully I'll gain something from it as well!

Everyone having problems in this thread should follow the instructions in the following thread.

Please note that the instructions are different depending on what version of OctoPi (a derivative of Raspbian-Lite, 0.14.0 = Jessie, 0.15.1 = Stretch) and what Raspberry Pi model (3B or 3B+). The RPi3B can run either Jessie or Stretch, the RPi3B+ must run Stretch (or later).

If you still have problems, make sure to provide the model of your Raspberry Pi, the version of OctoPi you installed, the OS and editor you used if you modified /boot/octopi-wpa-supplicant.txt before putting the SD card in the Raspberry Pi and if you tried (or can try) with an Ethernet cable connection.

What works for me....
wifi won't work unless country is set properly

Move Country before your "network"

country=AU # Australia

WPA/WPA2 secured




I had my pi 3B working on my home network, then moved it to my work network and had similar trouble. It turned out that the 2.4GHz band was full of noise. I was able to get a signal by moving the pi within 2m of the router, but it was fairly glitchy even then. The only answer was to use eth0 for reliable results. The noise is likely from a neighbor with a cheap webcam that is constantly filling the whole spectrum with garbage. After I got in the network I had to do some configuring through haproxy to get my webcam going. You may also want to check those settings of things still aren't working out.

Do you have admin access to the router? You may can change the WiFi channel.
Or is the 2.4 GHz band completely polluted?

1 Like

Also had issues connecting to wifi on my RPi3B v1.2 (using img: 2018-04-18-octopi-stretch-lite-0.15.1)

I could find my access point fine with: sudo iwlist wlan0 scan it just didn't want to connect.

Moving the country code to before the "network" seemed to fix my issues strangely also (it was correctly configured)

1 Like

I've heard in several places now that people could not get connected to WiFi unless the moved the Country setting to come before their "network" section. Mine works just fine on a Pi 3B with the Country setting in the default location (near the end of the /boot/octopi-wpa-supplicant.txt file).

It's interesting to note that the older versions of OctoPi had the Country setting at the top of the /boot/octopi-wpa-supplicant.txt file (a lot of people never saw this in the older versions, since they used the octopi-network.txt file to set up their network).

Still, I'm not sure why it would matter. The settings in the octopi-wpa-supplicant.txt file are just linked to the wpa_supplicant.conf file in a directory on the other partition. The information is copied over on boot-up. I would not think the order it is listed in the /boot/ partition file would make a big difference. But then I'm no guru in how this actually happens.

If @foosel or @guysoft confirm that this could make a difference, I'll add a note to the WiFi troubleshooting guide.

1 Like

I solved my problem..... The issue, a bad wifi router. Finally in exasperation, I tried a different router, et voila problem was solved. Note that the firewall settings were identical,

I note that if your wi-fi zone on your router is hidden then you need an extra line in your octopi-wpa-supplicant.txt file in the network section.


One difference of the plus version of the Raspberry Pi 3B is that the main chip has a new metallic shield over it. In theory, the shield conducts heat better so that they could squeeze an additional 0.2GHz out of the top-end speed.

Next, the wifi chip was moved from the bottom of the board. The chip antenna is gone, now replaced with the PCB antenna design from the Raspberry Pi Zero W. They added 802.3az Energy Efficient Ethernet to the LAN device.

Analysis: Is it possible that the new plus version has shorter wi-fi range as a result of the many changes in this area?

@rblum - If you have solved the problem, please check the little resolved icon in your post that describes the solution.

After much head banging and formatting and refreshing several times. I changed the country to UK, saved then back to US saved and then added the SSID/password and within 30 seconds of reboot it was visible on my wifi router. RBpi 3 B+ with octoprint 16

OctoPi 0.16*

I was having issues getting wireless started. I read through the posts here (thanks much to all the contributors) but it turns out I had only uncommented the ssid="MySSID" and psk="MyPassword" lines in the config file, leaving the network={} out.

Hoping this helps other idiots. What finally gave it away--and this may help others--was running
$sudo wpa-supplicant -c/boot/octopi-wpa-supplicant.txt -Dwext -iwlan0
and seeing the error messages parsing the config file.

Or just follow directions more carefully...

1 Like

I created an account to say thanks you help this idiot. Ive worked in IT for 16 plus years and that # next to the } was completely missed for like an hour. Thanks again.

I need some help.
I have an rpi 3 b clone made by Kano
it is pratically identical, aside from it not having an ethernet port.
I attempted many times to run octopi on it, but it would shut down after about a minute of it running
since I have it connected to a monitor, I can constantly see what is happening on it
Since that didnt work, I decided to put octoklipperpi on it through the rpi imager
I did the usual editing of the network and camera settings on the docs on the sd using vscode (not texteditor)
and after i ran it, it doesnt display any problems
but just refuses to connect to my network.
I have checked the details a countless number of times but am still doesnt connect
on the screen it says, "You may now open a web browser on your local network and navigate to any of the following addresses to access OctoPrint
https is also available, with a self-signed certificate."
then it says some other { Ok } stuff and then says, "octopi login [ OK ]
and some other stuff after that
i did all of this work on a mac btw
can someone tell me what to do? thanks
im also pretty sure that the green light on my pi is busted

If you have a keyboard and monitor connected, please try running through the WiFi troubleshooting guide.
WiFi setup and troubleshooting

If you still have problems after running through that, please share the results of the commands mentioned in the "Other Diagnostic Commands" section of that document.