🇺🇦 We stand with Ukraine! 🇺🇦

Pi 3 model B unable to connect to WIFI

@rblum - If you have solved the problem, please check the little resolved icon in your post that describes the solution.

After much head banging and formatting and refreshing several times. I changed the country to UK, saved then back to US saved and then added the SSID/password and within 30 seconds of reboot it was visible on my wifi router. RBpi 3 B+ with octoprint 16

OctoPi 0.16*

I was having issues getting wireless started. I read through the posts here (thanks much to all the contributors) but it turns out I had only uncommented the ssid="MySSID" and psk="MyPassword" lines in the config file, leaving the network={} out.

Hoping this helps other idiots. What finally gave it away--and this may help others--was running
$sudo wpa-supplicant -c/boot/octopi-wpa-supplicant.txt -Dwext -iwlan0
and seeing the error messages parsing the config file.

Or just follow directions more carefully...

1 Like

I created an account to say thanks you help this idiot. Ive worked in IT for 16 plus years and that # next to the } was completely missed for like an hour. Thanks again.