Pi Cam not detected by OctoPrint


#1

What is the problem?
My Pi Cam is not detected by OctoPrint. I don't think it's detected by OctoPi either, but I'm not an expert. On the Control tab, it gives the error " Webcam stream not loaded". In Settings > Webcam & Timelapse, the test gives the broken image link graphic.

What did you already try to solve it?
Restarted OctoPrint
Restarted Raspberry Pi
Tried shorter cable
Made sure that the cable was firmly seated and clamped in the Pi Cam and Raspberry Pi
Checked a couple of videos to make sure that I had been installing the cable correctly

Additional information about your setup
Raspberry Pi 3B v1.2
OctoPrint version : 1.3.9
OctoPi version : 0.15.1
Pi Cam V2-8

lsusb output
Bus 001 Device 004: ID 0403:6001 Future Technology Devices International, Ltd FT232 USB-Serial (UART) IC
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp. SMSC9512/9514 Fast Ethernet Adapter
Bus 001 Device 002: ID 0424:9514 Standard Microsystems Corp. SMC9514 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

/var/log/webcamd.log
Starting up webcamDaemon...

--- Configuration: ----------------------------
camera: auto
usb options: -r 640x480 -f 10
raspi options: -fps 10
http options: -w ./www-octopi -n

No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes
No camera detected, trying again in two minutes


Trying to get Raspberry pi Camera to work
#2

What about the cam led? Does it lights up red?


#3

@Johnnie_Walker there's an LED on the camera? I didn't know that, so that's a no.

Does that mean that the camera is defective (since I have tried it with 2 cables)?


#4

Yes. There is a red small led at the top right.


#5

@Johnnie_Walker mine is definitely NOT on. Would you call that a defective camera then? The cables are definitely plugged in correctly.

I also went into raspi-config and made sure that the camera interface was on.


#6

Could be a problem at one of the connectors. If you have another Pi, or some friend of yours would be easy to test.

And don’t connect or disconnect the camera with the Pi on. It’s not an USB port.


#7

Yep, I remembered to unplug the Pi before making changes.

I totally forgot that I had another Pi. It doesn't work with that one either. OctoPi doesn't see it, no light. Guess I need a new Pi Cam.


#8

Too bad it´s dead. I think it´s very useful, but would be nice to have a camera with a wide angle lens. Once your is dead, I would recommend you to look for one like this. I have the Pi Cam attached to my heated bed and when I print larger objects I don´t get a good timelapse.

Just rememebered something that you can look before changing the camera. Is it enabled at raspberry config?

sudo raspi-config
Choose 'Interfacing Options'
Enable the camera
reboot