Pi Camera on Raspberry PI 4 works in terminal but not in octoprint

OctoPrint doesn't even know that your webcam exists (it only knows about two URLs, one to embed in the UI, one to fetch stills from, that's all it has to do with cameras), an update of OctoPrint cannot influence the webcam server. So this is very likely unrelated and coincidence.

So, am I reading this thread right so far that picams won't work with mjpg-streamer on bullseye? If so, that is a major show stopper for a new OctoPi release for now.

i created another thread and posted the log.

not sure what happened, since it was working fine for over a year.

Hi there, I installed Octoprint on a Pi4 with Pi camera Rev 1.3 about four weeks ago and it runs with 1.7.2 without any problems. That's just for info.

browser.user_agent: Mozilla/5.0 (iPad; CPU OS 15_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Mobile/15E148 Safari/604.1
connectivity.connection_ok: true
connectivity.enabled: true
connectivity.online: true
connectivity.resolution_check: octoprint.org
connectivity.resolution_ok: true
env.hardware.cores: 4
env.hardware.freq: 1500
env.hardware.ram: 1903988736
env.os.bits: 32
env.os.id: linux
env.os.platform: linux
env.plugins.pi_support.model: Raspberry Pi 4 Model B Rev 1.4
env.plugins.pi_support.octopi_version: 0.18.0
env.plugins.pi_support.throttle_state: 0x0
env.python.pip: 20.3.3
env.python.version: 3.7.3
env.python.virtualenv: true
octoprint.safe_mode: false
octoprint.version: 1.7.2
systeminfo.generator: systemapi

You are using OctoPi 0.18, which is the stable release, rather than the nightly builds being tested here. They are based on different OS versions, the camera stack has changed.

1 Like

This is unrelated to the discussion in this thread.

That's development work for the next version of OctoPi, based on Debian Bullseye.

OctoPrint and OctoPi are two different things. You have a completely separate problem to this thread if you don't know what that fix is for or what bullseye means.

anyways. went back to 1.7.2 with Sudo command to rollback and camera stays white now in the test screen, and not a thumbnail, but still not working.

Which confirms what I said, this had nothing to do with 1.7.3 (and it technically also can't, two separate things, OctoPrint not having a clue what a webcam even is let alone controlling it) but is another issue that coincided and which has nothing to do with this thread.

Hi everyone, now I was so glad that everything is working for me. Unfortunately today I updated to 1.7.3 and since then I've had the problem with the Pi ver. 1.2 camera that it responds with a very time lag. That means with about 1min offset. sometimes faster. I've now flashed the 1.7.3 and the night version again, but to no avail.
When I call up the camera, it also takes a very long time for a picture to appear, as long as it writes that it is loading. I tried to go back to 1.7.2 but I couldn't do it

Edit: back to 1.7.2 and it works again immediately

Apparently something must have changed in the new 1.7.3, even if it wasn't intended. it kinda felt like a memory overflow like the stream was lagging.