Pi Camera V3/IMX Chipset Based Cameras Not Working

I'm still operating fine with the RC build of OctoPi 1.0 and the script prepared by @ltlowe

Other than presumably, full 1080p, I'm hesitant to update to the official support just yet as Github still has people complaining.

Anyone else make the switch/upgrade and is happy that they did?

I'm not sure where you got the impression that there aren't people happy with the image from the OctoPi-UpToDate GitHub. I can count the vast majority of comments in the GitHub issue being positive 'it works', with maybe a couple of issues that are unsolved. A lot of problems have been solved in that thread.

It's completely up to you whether to switch, at the end of the day you are unlikely to gain much, I was just wondering why the GitHub issue made you hesitant to do so.

I'm sorry, are you honestly talking about this? Feedback for the new camera-streamer based webcam stack · Issue #2 · OctoPrint/OctoPi-UpToDate · GitHub

In what world are the posts there a "vast majority" of "it works"?

I have to hunt around and read full comments just to find 1 or 2. If it works, great, I'm happy to switch, but your post is weirdly condescending.

I can see how that thread could be daunting and misconstrued as having all kinds of issues, but since the last build release mentioned toward the end there have been several confirmed successes.

So I went ahead and jumped in. Oddly though, the OctoApp reports the resolution as 1056p which is the same resolution the scripting above reported.

What's the best way to discern what resolution is being shown? I changed the contents of libcamera.conf to the below and rebooted:

# The resolution to request on the camera sensor. Defaults to 1280x720.

# The height to use for the video stream. Defaults to 720.

# The height to use for the snapshots. Defaults to 1080.

# The framerate to set on the camera. Defaults to 15fps.

# Additional options. By default enables continuous auto focus (if possible).
OPTIONS='-camera-options="AfMode=2" -camera-options="AfRange=2"'

I'd just like some sort of confirmation I guess. 1056p in OctoApp is puzzling to me.

1056 is the height of the stream that you're seeing I would suspect. I have just poked at mine (Pi Cam V3, and with the same configuration I'm seeing a stream of 1920x1056, not 1080. Saving an image from the snapshot URL show the same thing.

camera-streamer seems to indicate the camera won't give it 1920x1080, at least for the snapshot:

Mar 24 21:58:33 rpiblue sh[675]: device/v4l2/buffer_list.c: SNAPSHOT:output:mplane: Requested resolution=1920x1080 is unavailable. Got 1920x1088.
Mar 24 21:58:33 rpiblue sh[675]: device/buffer_list.c: SNAPSHOT:output:mplane: Using: 1920x1056/YUYV, bytesperline=3840, sizeimage=3.9MiB

So it does then decide to use 1920x1056 instead. I can't explain why at the moment, but can confirm it's not something specific to your setup.

I appreciate you looking. I won't spend any more time on it then.

Everything else does look good.

Printer - Ender 3 S1 Pro
Pi - OctoPi 1.0.0 with OctoPrint 1.8.7 (build 20230328122604 from branch camera-streamer)
Camera - Pi Camera Module 3
Ribbon Cable - Adafruit Flex Cable for Raspberry Pi Camera - 2 Meters [ADA2144]
Issue - Cannot get a focused image to display.
Attempted Solutions - I have attempted just about everything in this post to fix this issue but cannot seem to get my camera to focus.

Make sure that you don't have a case on the camera that might be touching the lens - that seems to have caught a few people out already on the focusing issues. Out of the box that OctoPi build you posted worked for me with a Pi Cam V3 and autofocusing, but I have no case on the camera or anything like that.

That was definitely it! Took the case off and it focused right away! Thanks for that one, I spent like 6 hours yesterday redoing step by step, changing variables here and there and nothing was working. Something so simple.

And after a lot of fiddling, searching, and speaking interesting Dutch words, I learned how to make an SD card extender working on a Pi. The surface mount resistor on the PCB needs to be removed, otherwise, the Pi doesn't work. See the explanation here (scroll down a bit) RPi4 with MicroSD Extender Boot Failure - Raspberry Pi Forums

Pi 4B, Cam module V3 - I had the camera working through OctoPi using cam3install.sh. I accidentally unplugged cam when the Pi was running - I clipped it in and booted the Pi but I get Server Error on /webcam/?action=stream now. I removed the installation and reinstalled it but I still get the Server Error.

The service camera-streamer-pi708-12MP is active.

Not sure what changed since I unplugged the camera.

This is your first post to our forums and it is the 130th post to this topic. You are not sure what changed and neither are we given the limited input you have provided.

I strongly suggest that you open a new Get Help topic and fill out the template with as much detail as you can. The more information you provide, the better chance we have of providing help.

1 Like

please how to get to - /home/pi/camera-streamer/service/camera-streamer-pi708-12MP.service
thank you

if you're logged in via ssh you can use nano (you can exit nano and save the file with ctrl + x)

nano /home/pi/camera-streamer/service/camera-streamer-pi708-12MP.service

or use a gui file explorer like WinSCP

thank you, I've got it

Am i only one who has problem with pi camera V3 after this steps? Thank you for your feedback

@Albert_Van_Wesemael, This topic has 135 entries and without any more information from you besides "Am I only one who has a problem..." there is not going to be much feedback from us.

I strongly suggest that you open a new Get Help, Webcams topic and fill out the template with as much detail (there's no such thing as too much detail) including the version numbers of everything you have along with details on the steps you have taken and any error messages you have received.

We can then give you the personalized attention you need to get things working.


Thank you, Stefan. After spending the last 24 hours pulling my hair out, I eventually came across your comment and my new RPi4B with Pi Camera module v3 is working perfectly in OctoPrint v1.9.0.

The script worked perfectly for me with Raspberry Pi Zero 2W
I did the swap script from @Caouch before and enabled "legacy camera support" like @quichua007 said

The camera is detected perfectly, I tried the new camera stack Octopi version but it keep freezing after a print is completed