Pi zero 2 w micro usb issues

What is the problem?

Pi loses connection to printer during print

What did you already try to solve it?

Tried 3 different micro usb adapters including the official Pi one as well as 3 different micro usb cables. All 3 work perfectly when connected to the pc directly. Tried 2 different Pis as well.
Sometimes the serial connection isnt even detected until I unplug and replug the printer in via usb

Have you tried running in safe mode?


Did running in safe mode solve the problem?


Systeminfo Bundle


Additional information about your setup

OctoPrint version 1.8.0 I think , OctoPi version 1.0.0, ender 3 v2, Jyers UI latest version available, browser, operating system,

The print will stop at different times with octoprint reporting communication errors to the printer. Sometimes errors will occur and then it will come right and keep printing, other times it will have soo many errors it stops the print altogether
octoprint-systeminfo-20231006215719.zip (52.4 KB)

Hello @RichyRich !

This can be caused by EMI:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.