Printer is extruding too high

What is the problem?

Prints are printing about 5mm above my print bed after updating to 1.5.0

What did you already try to solve it?

I have used several slicers and several files. Recalibrated BLTouch, updated OctoPrint, Printed in safe mode.

Have you tried running in safe mode and if so did it solve the issue?

I have with no change.

Complete Logs

serial.log (148 Bytes) )

Ender 5 Pro, OctoPrint 1.5.1, Cura (most current), S3D (most current). Mac Big Sur

It finished the print above like some kind of ooze raft which is what is confusing me. I have messed with all of my z axis calibrations as well.

Any help would be appreciated!


via the printers display or with a plugin?

I used the printers display and when that didn't work I attempted to calibrate it with the plugin.

Edit: The plugin is not currently installed because I removed it to try it without it.

mhmm weird
does it work when you print the same file via sd card?

btw did you read your serial.log :wink: ?

I breifly read it, my wife is pregnant so i get to do this in 5 second intervals haha I tried printing USB and the printer can't level itself.

Edit; im dumb ill get a real log uploaded

OctoPrint does not change commands it sends out, it does not modify your printer's z height. It streams to your printer whatever is in your files, line by line. It cannot make your prints end up 5mm too high, 12mm too far to the left or upside down on its own. That all needs to enter its send queue either through the gcode file from your slicer or the gcode scripts you configured or by commands entered by you or installed plugins.

Thats what I figured I am posting this as a last resort because none of my slicers have changed and none of my other settings. I just wanted to see if it was possible for OctoPrint to possible distort a gcode or if that isn't a possibility so I can keep troubleshooting. I am sorry if this is not the place to go but every other forum I have posted in has yielded no answers. Im getting print withdrawals haha. My OctoPrint.log is too big to upload because I think I have my settings messed up to where it doesn't segment the logs into individual prints but every print I have ever done. Should I still find a way to upload it or do I need to look outside OctoPrint for the issue?

Recv: Bilinear Leveling Grid:
Recv: 0 1 2
Recv: 0 +0.186 -0.121 -0.476
Recv: 1 +0.334 -0.056 -0.280
Recv: 2 +0.019 +0.049 -0.030
Recv: echo:enqueueing "G0 F3600 X115 Y112"
Recv: X:170.00 Y:170.00 Z:9.93 E:0.00 Count X:13600 Y:13600 Z:8000
Recv: ok
Send: N10 G1 X5 Y10 Z0.2 F300031
Recv: ok
Send: N11 G92 E0
Recv: X:5.00 Y:10.00 Z:0.20 E:0.00 Count X:13485 Y:13479 Z:7997
Recv: ok
Send: N12 G1 X160 E15 F600101
Recv: ok
Send: N13 G1 X180 F5000
Recv: ok
Send: N14 T015
Recv: echo:Active Extruder: 0
Recv: ok
Send: N15 G92 E0.0000
Recv: X:180.00 Y:10.00 Z:0.20 E:0.00 Count X:12661 Y:12610 Z:7978
Recv: ok
Send: N16 G1 E-6.0000 F250244
Recv: ok
Send: N17 G1 Z0.200 F1002
Recv: ok
Send: N18 G1 X97.162 Y98.825 F4800127
Recv: ok
Send: N19 G1 E0.0000 F2502
Recv: ok
Send: N20 G92 E0.000091
Recv: X:97.16 Y:98.83 Z:0.20 E:0.00 Count X:12138 Y:12058 Z:7965
Recv: ok
Send: N21 G1 X98.825 Y97.162 E0.0924 F1500
Recv: ok
Send: N22 G1 X121.175 Y97.162 E0.970583
Recv: ok
Send: N23 G1 X122.838 Y98.825 E1.0628
Recv: ok
Send: N24 G1 X122.838 Y121.175 E1.9410106
Recv: ok
Send: N25 G1 X121.175 Y122.838 E2.0333
Recv: ok
Send: N26 G1 X98.825 Y122.838 E2.911485
Recv: ok
Send: N27 G1 X97.162 Y121.175 E3.0038
Recv: ok
Send: N28 G1 X97.162 Y98.825 E3.8819102
Recv: ok
Send: N29 G92 E0.0000
Recv: X:97.16 Y:98.83 Z:0.20 E:0.00 Count X:14365 Y:837 Z:-382
Recv: ok
Send: N30 G1 E-6.0000 F2502*40

Have you tried in safe mode, with a freshly uploaded file while in safe mode? There are plugins that modify your gcode on upload.

I did try it in safe mode with 3 different slicers that I had reset to default values. I am now wondering if my Z stop somehow got moved because looking at where the nozzle should be presses down the switch well past activation point. I don't know if my BLTouch moved when I wasn't looking but it is still in line with the standard mount and comes down about 6mm past the nozzle tip. I don't read GCODE very well and I know you wrote the BLTouch plugin so can I ask does it look to you like it is sending the proper code?

The only z value in your gcode is here: 0.2mm, which sounds like the first layer is correct. Definitely look at hardware issues, make sure nothing has come loose (like the endstop & BLtouch, and you might also want to look at your Z offset value (send M851 command).

Not exactly, there is one at the beginning too, moving to 9.93. So I'm curious if this a relative/absolute movement issue. I don't see an open ended G92 command, they are all specified with the E parameter. Curious @Trickflowdoes the first layer print at approximately 10mm in the air?

Yeah almost exactly

Try adding G91 to your start gcode right after the G29.

Correction G90, just realized that G92 is specific to extrusion, G90 is Absolute movement, G91 is relative movement. So what was happening is you were homing and then ending up at 9.93 and then when your gcode says to move to 0.2 it was just moving .2mm up, not going to the absolute position 0.2 from the bed.

Ok ill run a print and see what happens, thank you for taking the time time to help!
Edit: Ran a new print with G90 after G29 and this is about where the hot end is.

Its definitely closer, about 2mm above the hot bed.

interesting, that almost sounds like the offset isn't loaded. what do you get if you send the command M851 to the printer before & after homing & leveling.

Before G29

Send: M851
Recv: echo:Z Offset : 0.00

After G29
Send: M851
Recv: echo:Z Offset : 0.00

Yep, so you haven't set your offset for the z. You need to set that. Do G28 followed by G29 and then once it's done and lifts up, use the control panel to move down. Keep incrementing it down until you can do the paper drag test thing under the nozzle (don't move the screws just the nozzle). Once you get to the correct feel with the paper run the following command.


you should get back something like this where the Z will be negative. You will use that in the next command.

Recv: ok X:0.0 Y:0.0 Z:0.0 E:0.0 Count: A:0 B:0 C:0

Run the following command based on what you see as the z (no brackets)

M851 Z<distance offset> ;set the z offset
M500 ; save settings to EEPROM

Then in theory I think you can run M114 again and it will return a Z of 0 (not 100% sure on this).

I got this after running the commands.
Send: M114
Recv: X:115.00 Y:112.00 Z:12.31 E:12.43 Count X:9200 Y:8960 Z:9732

Before it was -2.29 so lets give this. a run

checkout this video fro setting z offset works like a charm!