Printer Printing In The Air

What is the problem?

I am printing on my Ender 3 Max with a Octopi. When I start a print from my card the printer will auto home then print the purge, then auto home again. (I am not really worried about the double home) The printer will either print normally, or the more common; print in the air. I have absolutely no clue what is causing it. As well, the printer prints at the right height after the first homing for 1-2 seconds then it homes again and most of the time prints in the air.

What did you already try to solve it?

I have tried to run the printer without the pi and it worked perfectly fine.

Have you tried running in safe mode?

I have also tried running it in safe mode.

Did running in safe mode solve the problem?

It didn't fix the printing in the air or the double homing.

Systeminfo Bundle

You can download this in OctoPrint's System Information dialog... no bundle, no support, unless the reason you couldn't retrieve the bundle is your network issues


Additional information about your setup

Hardware you are trying to connect to, hardware you are trying to connect from, router, access point, used operating systems, ... as much data as possible

I have the pi connected to the printer with the (micro?) usb port next the the card slot. I used the included cords to power the pi and prevent power from the printer messing with the pi.

Hello @Pepisman026 !

Please enable the serial.log, try again and then attach (as it was already requested) the systeminfo bundle to your next post.

Not sure how to do that.

Blue words like serial.log are links and give you further information.

Can I view the log before i download it? Sorry for asking so many questions.

It would be easier to look at it after you downloaded it.

Just open it in a text editor of your choice :slight_smile:

That's not the one we need :slight_smile:

The serial log logs the communication between octoprint and the printer so we know what exactly happened.

Best would be to enable it, then start a print until the issue occurs again an then upload the bundle - or if you prefer it just the serial.log.

Then we see what's going on.

I enabled the serial.log setting and started a test cube. The printer skipped the second auto home and is printing normally. I am going to test the printer more and see what happens.

1 Like