Printing does not start

What is the problem?

I have just installed Octoprint for the first time.
Everything seemed to work fine but I can't get a single print to run.
The temperature adjusts correctly and then... nothing!
There is also something that strikes me, when I manually move the nozzle or the bed, the extruder starts up at the same time. The only way to stop this is to reflash my EEPROM every time.

I can't cancel a print run. The console stays stuck on "cancelling".

What did you already try to solve it?

I have searched the net and the forum for a similar topic but I can't find any.
I also repeat that this is the first time I use octoprint and I am a bit lost.

Have you tried running in safe mode?

I also ran it in safe mode and absolutely nothing changes

Did running in safe mode solve the problem?


Systeminfo Bundle

You can download this in OctoPrint's System Information dialog ... no bundle, no support!) (79.0 KB)

Additional information about your setup

OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible

I use a Creality CR-X Pro with Ocroprint 1.8.6 and a Raspberry 3+.
The firmware i use is the official Creality firmware :

Creatily_Marlin1.1.6_CR-X (124.0 KB)

Thanks a in advance !

Hello @Jay68480 !

The printer does not reach the desired temperature:

2022-12-27 10:30:12,097 - octoprint.util.comm - WARNING - Received an error from the printer's firmware: Heating failed, system stopped! Heater_ID: 0 - ok
| Last lines in terminal:
| Recv:  == T:192.22 /200.00 == B:38.73 /0.00 @:0 B@:0 W:?
| Recv: echo:busy: processing
| Recv:  == T:191.90 /200.00 == B:38.73 /0.00 @:0 B@:0 W:?
| Recv:  == T:191.82 /200.00 == B:38.71 /0.00 @:0 B@:0
| Recv:  == T:191.48 /200.00 == B:38.67 /0.00 @:0 B@:0 W:?
| Recv: echo:busy: processing
| Recv:  == T:190.74 /200.00 == B:38.67 /0.00 @:0 B@:0 W:?
| Recv:  == T:189.61 /200.00 == B:38.67 /0.00 @:127 B@:0 W:?
| Recv:  == T:188.70 /200.00 == B:38.67 /0.00 @:127 B@:0
| Recv: echo:busy: processing
| Recv:  == T:188.41 /200.00 == B:38.67 /0.00 @:127 B@:0 W:?
| Recv:  == T:187.45 /200.00 == B:38.65 /0.00 @:127 B@:0 W:?
| Recv: echo:busy: processing
| Recv:  == T:186.67 /200.00 == B:38.65 /0.00 @:127 B@:0 W:?
| Recv:  == T:186.25 /200.00 == B:38.67 /0.00 @:127 B@:0
| Recv:  == T:186.25 /200.00 == B:38.65 /0.00 @:127 B@:0 W:?
| Recv: echo:busy: processing
| Recv:  == T:186.25 /200.00 == B:38.63 /0.00 @:127 B@:0 W:?
| Recv: Error:Heating failed, system stopped! Heater_ID: 0
| Recv: ok

Is the printer at a cold place?

Oh my bad, I don't know if the log I sent you is up to date! Indeed, after research, I fixed this temperature problem with a PID Tuning :slight_smile:
The rest is still a problem.

By 'the rest', are you meaning that the original topic of 'Printing does not start' is solved? What exactly works and doesn't work now?

Are these the remaining problems?

It might help to enable serial.log, reproduce the issue, and then share the file so we can see the communication with the printer.

Good evening, I can confirm that the problem is still ongoing, the prints are not being launched.

No, these are additional problems detected during my research.

I have just searched on the net how to have the serial.log, I recreate the problem and I link all that.

Thanks a lot!

Just click the blue words serial.log

Octopi is so simple... it just has to work now lol

Here is my serial.log :

serial (2).log (169.8 KB)

If, however, I am able to provide all possible tests.

Someone ? Halp ?

Actually the print starts, but only up to line 56 and is cancelled about 35 seconds later.

That was my understanding. But physically my print has not started! :confused:

Are you able to move the Axis of the printer using manual command from the Octoprint interface? If not, check that your Servo motors are connected at the board and the motor.

Does it run when you print from SD card?

Does it run when you print from pronterface?

Yes I can move my shafts manually, but then the other problem mentioned above arises, the extruder rotates at the same time as my axis.

It works well via the SD card or via the interface. It is only with Octopi that I have problems

For the record, my printer stopped running the extruder at the same time as the axis after changing firmware. It's hard to understand.

I don't know if I can express myself well, but I can make a video if you are interested.

Can you confirm that you have tried using Pronterface and that it works as expected when using it?

I can confirm this, as soon as I saw your post I immediately launched a test cube with pronterface. CLEAR

Are there any known problems between firmwares and octopi versions ?

It seems, the Creality CR-X is a bit problematic:

You may should think about another firmware.

@Ewald_Ikemann Thank you so much !!!!

I finally managed to solve the problem and it was thanks to an answer you gave on the first topic you sent me...!

After removing the SD card, I was able to print without any problem and with the original firmware.

It's really incredible :sweat_smile: :rofl:

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.