Problem: Can't install 3rd party plugins


  1. I installed Debian to dual boot on old Windows 7 laptop because the laptop doesn't meet requirements for upgrade to Windows 10. Hence I can't install suitable version of python to run Octoprint on Windows 7. Yes, I can afford a Raspberry pi but I have the laptop and don't want to throw it away. It has been an opportunity to learn something by trying Linux.
  2. The old guy has finally learned enough to get Debian up and running and actually likes using the terminal command line. Octoprint service is up and running nicely on the laptop. And, I can access it via wifi connection from all computers on my network.
    Actions: I've researched every similar problem in the OctoPrint and Linux (mainly Ubuntu) forums and tried the suggested fixes- using the plugin manager, command line installation, installation from the bin directory and also with the venv virtual environment activated. I have also researched the error messages for solutions to no avail. I've been to * Bed Level Visualizer

Selecting the checkbox "Use --process- dependency-links with pip install immediately causes "Sadly the repository is currently not available Is your OctoPrint installation connected to the internet?" I check and it is but the repository is not and will not refresh.

The best information I have is :

pi@CDGdebian:~/OctoPrint/venv/bin$ pip3.9 install ""
Defaulting to user installation because normal site-packages is not writeable
Using cached
Preparing metadata ( ... error
error: subprocess-exited-with-error

× python egg_info did not run successfully.
│ exit code: 255
╰─> [1 lines of output]
Could not import OctoPrint's setuptools, are you sure you are running that under the same python installation that OctoPrint is installed under?
[end of output]

note: This error originates from a subprocess, and is likely not a problem with pip.
error: metadata-generation-failed

× Encountered error while generating package metadata.
╰─> See above for output.

note: This is an issue with the package mentioned above, not pip.
hint: See above for details.

Here is the systeminfo file: (17.5 KB)

I'd give up on it but I really like the Bed Level Visualizer plugin.
Cheers to anyone who can sort this out.

I have this issue with Debian 11. I have seen another post mentioning Debian 11 too.....

Can you try to install the wheel package in your venv? Running ~/OctoPrint/venv/bin/pip install wheel, then try installing the plugin again?

OctoPrint 1.9.0 (currently in RC testing phase) forces this to be installed, so that pip 23.1 installs the plugins using that rather than building in a new isolated mode.


190rc fixed it. Cheers legend.

Thanks for the response from a Charlie to a Charlie. But alas, I get the same result as before, prefaced by:
Defaulting to user information because normal site packages is not writable Requirement already satisfied: wheel in /home/pi/.local/lib/python3.9/site-packages (0.40.0)

However, what was not clear to me was if I needed to "Activate" the virtual environment, so I tried
(venv) pi@CDGdebian:~/OctoPrint/venv/bin/pip install wheel
Collecting wheel
Using cached wheel -0.40.0-py3-none-any.whl (64 kB)
Installling collected packages: wheel
Sucessfully installed package wheel -0.40.0

Voilà, the plugin sucessfully installed.

I suppose a little knowledge is a dangerous thing- because I don't know what "building in a new isolated mode" means. I assume it is Python related and the workings of virtual environments. And, I don't know anything about Python. Many thanks for taking pity on someone who learned Fortran in the days of wooden ships and iron men, i.e., punch cards.

Thanks for posting. I was not keen on switching my version 1.8.7 to 1.9.0 in RC testing. Charlie's command fix was spot on once I figured out I needed to execute the command in the virtual environment.

I was hoping that the command with the full path would avoid the need for activating the environment, but at least you got that fixed. By not upgrading to 1.9.0rc you've confirmed that the fix I was thinking of that is included in that version does in fact solve this problem.

I'm so glad to have found this, thank you.

I was experiencing the same error on rebuilding my OctoPrint instance. In fact, my restore completely failed due to this. So hopefully I can get things back together now.

1 Like