Problem Connecting to Printer (EcubMaker TOYDIY)

I'm new to this and after a couple of days trying without any luck to solve my problem I decided to ask for some help from some almighty god. I have an EcubMaker TOYDIY after seeing everything about OctoPrint it look perfect so I gave it a go but unfortunately I'm not able to maintain a connection to my Printer. For some reason the problem seems to be that on the hello command my printer is not replying to it.

What did you already try to solve it?

  • Restarted on Safe Mode - Didn't Work;
  • Added the Command "M110" to Long running commands - Didn't Work;
  • Changed "Hello" command to M115 - Didn't Work;
  • Used pronterface to Connect to Printer and Use M110 - Got a reply;
  • Installed OctoPrint on PC - The same problem.
  • Starting without the SD card - Changed the error to:

There was a timeout while trying to connect to the printer
Changing monitoring state from "Connecting" to "Offline"
Connection closed, closing down monitor

Logs
serial.log (5.6 KB) octoprint.log (13.0 KB)

Additional information about your setup
OctoPrint version: OctoPrint 14.0
OctoPi: OctoPi 0.17.0
Printer: EcubMaker TOYDIY (uses an atmega2560)
Firmware: Marlin 1.2.5-ToyDIY (Github)
RaspberryPi 3B+

Hope that this is enough information if anyone needs more please let me know.

Any suggestions for me to try will be welcomed.

Hello @Diogo_Oliveira!

Have you already tried without the SD card in the printer?

Hi @Ewald_Ikemann!

Gave it a try. Still didn't work but changed the error message to:

Connecting to: /dev/ttyUSB0
Changing monitoring state from "Offline" to "Opening serial port"
Connected to: Serial<id=0x70c93e90, open=True>(port='/dev/ttyUSB0', baudrate=115200, bytesize=8, parity='N', stopbits=1, timeout=10.0, xonxoff=False, rtscts=False, dsrdtr=False), starting monitor
Changing monitoring state from "Opening serial port" to "Connecting"
Send: N0 M110 N0*125
Recv: start
Recv: echo:EcubMaker 1.2.5-ToyDIY
Recv: echo: Last Updated: 2018-12-19 11:16 | Author: (none, default config)
Send: N0 M110 N0*125
Recv: Compiled: Dec 17 2019
Recv: echo: Free Memory: 3398  PlannerBufferBytes: 1232
Recv: echo:V24 stored settings retrieved (412 bytes)
Recv: echo:Steps per unit:
Recv: echo:  M92 X80.00 Y80.00 Z400.00 E92.00
Recv: echo:Maximum feedrates (mm/s):
Recv: echo:  M203 X300.00 Y300.00 Z30.00 E100.00
Recv: echo:Maximum Acceleration (mm/s2):
Recv: echo:  M201 X400 Y400 Z400 E1000
Recv: echo:Accelerations: P=printing, R=retract and T=travel
Recv: echo:  M204 P400.00 R400.00 T400.00
Recv: echo:Advanced variables: S=Min feedrate (mm/s), T=Min travel feedrate (mm/s), B=minimum segment time (ms), X=maximum XY jerk (mm/s),  Z=maximum Z jerk (mm/s),  E=maximum E jerk (mm/s)
Recv: echo:  M205 S0.00 T0.00 B20000 X20.00 Z5.00 E5.00
Recv: echo:Home offset (mm)
Recv: echo:  M206 X0.00 Y0.00 Z0.00
Recv: echo:Material heatup parameters:
Recv: echo:  M145 S0 H200 B110 F255
Recv: echo:  M145 S1 H200 B50 F0
Recv: echo:PID settings:
Recv: echo:  M301 P16.74 I1.23 D56.78
Recv: echo:LCD Contrast:
Recv: echo:  M250 C120
Recv: echo:Filament settings: Disabled
Recv: echo:  M200 D3.00
Recv: echo:  M200 T1 D3.00
Recv: echo:  M200 D0
Recv: echo:Z-Probe Offset (mm):
Recv: echo:  M851 Z-0.50
**Recv: echo:SD init fail**
**There was a timeout while trying to connect to the printer**
**Changing monitoring state from "Connecting" to "Offline"**
**Connection closed, closing down monitor**

Thank you for the suggestion. Let's go for the next one :slight_smile:

Hmm - you may try this plugin: Malyan/Monoprice Connection Fix

OctoPrint "talks" to Marlin firmware using GCode commands as defined in http://marlinfw.org/meta/gcode/. OctoPrint expects responses consistent with those produced by "vanilla" Marlin.

Your printer isn't responding to the M110 with something it recognizes so you will need a plugin to do some "translation". The more your printer's firmware varies from the "Marlin standard", the more work the "translator" plugin will have to do.

Try enabling "wait for start on connect" if it isn't already enabled:

I tried to talk with the printer using Pronterface and I managed to send the code M110 and received a valid response so the printer understands the comand.

I tried that didn't worked neither. It continue with exactly the same error.

Share the output from pronterface here. And then share the output of OctoPrint when "wait for start" is active.

@Ewald_Ikemann and we have a winner. It worked my prints are taking a bit to load from the Pi to the printer and all but we have progress at least I can connect and maintain a connection to the printer. So I will mark this as the solution and them I'm going to do some testing on the rest to see if everything is working as expected.
Thank you so much for the help and for giving this a look :slight_smile:

1 Like

@foosel no need thank you so much for the help but with the plugin looks like the problem is fixed or at least I can maintain a connection to the printer without any errors. Again thank you so much for your time and for the help :slight_smile:

Some printer connection problems are the result of badly connected cables. Make sure that the printer's power cord is plugged into a mains socket and that the printer cable is properly connected to the computer. If your printer is connected to a USB port on your computer, check to see if the USB connection is at fault krogerfeedback

Hell @Brownes!
In this case it was a firmware issue that was resolved with the plugin.