Problem installing Czech translation

Hello
I found the problem in czech language pack for Octoprint version 1.4.0. With language pack for version 1.3.12 this problem is fixed.
I´m not sure what is wrong - the *.po file is downloaded from transifex - https://www.transifex.com/octoprint/octoprint/dashboard/
and converted to *.mo file by this page: https://ezgif.com/po-to-mo
Maybe some wrong characters in new translated strings ?
Somebody have same experince in the past?
I have attached both version of files for checking.
Thanks for your help.
Jan

cs_1_3_12.zip (115.0 KB) cs_1_4_0.zip (122.6 KB)

1 Like

[Moved to new topic]

I just tried to change all czech words "umožňuje" and "umožní" to "povolit", but it not help.
Another ideas?

Hello @foosel
Do you known if there is some possibility how to return the translation source file in transifex to state of version 1.3.12 only for czech version?
Or how to adjust transifex to show only strings which was added after version 1.3.12?
I tried adjust "Source updated after" but I´m not sure of date of first update after version 1.3.12

I will try translate it again "per partes" to find problematic string.

Thanks
Jan

Don't think that is possible.

Do you know exact date when you add new version to transifex after v. 1.3.12 ?

That happens fully automated on every release, so some moments after 1.4.0 was released.

Oh. OK
I know there was also some RC version because I remember also translating in more steps.
I will try somethink.
Thanks

Hello
The problem was my mistake - missing end point No. 4 in my translation (see on picture)

Final working files with czech translation:
cs_1_4_0.zip (122.4 KB)

Thanks for your help
Jan

1 Like