Problem setting up raspi camera and USB camera simultaneously with the new camera stack

Camera model

Raspberry Pi camera rev 1.3
Random USB camera that works alone (tested).

What is the problem?

Following various guides in the community, I am able to get both cameras streaming and am able to view these streams in new tabs of my browser by going to /webcam/?action=stream (for port 8080 camera) and :8081/stream. However, when I try to embed the camera with the multicam plugin, I cannot get the second (USB) camera's stream to show up.

What did you already try to solve it?

For URL, I tried and http://:8081/stream. Neither works.

Systeminfo Bundle (52.6 KB)

USB Camera config


Additional information about your setup

OctoPrint version 1.9.3
OctoPi Build 2023.10.09.154319 with "camera-streamer", based on OctoPi 1.0.0, running on Raspberry Pi 4 Model B Rev 1.5
Browser: Microsoft Edge Version 120.0.2210.77

Thanks in advance!

have you tried http://octopi.local:8081/?action=stream?

On another note, did you have any issues getting the pi cam 1.3 working? I've got the USB working, but cannot get the picam working for the life of me.

How did you access /boot? The folder doesn't exist when I SSH into it. I'm trying to get a USB Wyze camera to work

I installed using the Raspberry Pi Imager as outlined here. After that the /boot directory was just there.

I only have three folders in mine for some reason Octoprint, oprint, and scripts.

Sounds like your home folder. try "ls /boot"

Sorry for the late reply. Accessing that webpage does give me the camera stream of the USB cam, but putting that address in MultiCam gives me the Webcam stream not loaded error.

On the other hand, my pi cam 1.3 works perfectly fine. It is in the default port (8080, but accessed via the /webcam/?action=stream address). I configured my Octopi with only the pi cam present, and added the USB cam afterward, which may be why my pi cam is working, but not the USB cam.

What address do you use to access the OctoPrint UI from? For security, browsers don't allow you to mix local, private IP addresses with 'public' domains - and they don't know that octopi.local is actually private as well. If you access OctoPrint using the IP, also put the IP in the multicam plugin. If you put octopi.local in the plugin, you should also access OctoPrint using that.

I access OctoPrint UI via the IP, either within my home internet or over tailscale. I can access OctoPrint UI with or 111 (one is ethernet the other is wifi. I just found out about this too), but I cannot see the camera stream by going to either of their 8081 ports. Do you reckon the two internet interfaces being used concurrently may be causing issues?