Problem with X-axis crash

What is the problem?

Same Problem with XY Homing crash likes the post from Hank_Patel, but i have the Pi 4 with 4GB

Could already find something similar, unfortunately it didn't help me,
but it should not be due to the firmware, or at least.

Got Marlin 2.0.5.4 on it and an Anycubic Mega S

when I approach the axis via Home all it doesn't happen, but I control it via Octoprint
with the keyboard and the arrow keys, (on the X-axis) there is a collision at the end stop,
so the end stop has no function and it rattles against the mechanical end.

I checked all cables and I also inserted an SD card.

What did you already try to solve it?

Insert SD Card and check the cable management

Have you tried running in safe mode?

Yes

Did running in safe mode solve the problem?

Same Problem

Complete Logs

serial.log (38.9 KB)
octoprint.log (1.5 MB)

Additional information about your setup

OctoPrint version 1.5.3, OctoPi 5.4.83, printer, firmware Marlin 2.0.5.4, newest Firefox, operating system W10, Printer Anycubic Mega s

Did you home the axis before you moved them with the arrow keys?

yes, once axes XY, then Z and only each individually ...
Unfortunately no improvement.

Just tested it on one of my printers
My axis also crashes - but only if the printer is "unhomed".
After homing either the real endstop or the softendstop prevents any crashes.

I guess your softendstops are disabled for some reason.
Try to enable them with M211 S1

Could reproduce that now and it works.
I saved the command with M500.

But it works only when I have to put the axes in the homeposition.
It doesn't work without homeposition, thank you very much ....

One more question, can I instruct Octoprint to automatically drive to the home position after 'connecting' ?
If I should forget to drive homeposition, there is no longer a crash.

You can add custom gcode to afterPrinterConnected gcode script, such as G28. Though be careful you don't connect with a print on the bed or something.

GCODE Scripts — OctoPrint master documentation

thanks for your help.
Now I was just about to print and notice that, the Home Z axis no longer fits.
Even when it comes to bed leveling, it doesn't work anymore, can that be?

How can I do a mechanically restore for the zero position ???
Sorry I haven't been a newbee...

What do you mean by that?
Is the Z-offset wrong?

yes,

i went to "Home all" and the Z-axis is to low, I guess 1-2mm.
I can see the bed being pushed down.

Should I make a mechanical adjustment or make an offset.?
How can i do this??

I also tried again with the mesh leveling, the same....
What can I do now?

It depends on whether you use a probe for Z or microswitch

If you're using a microswitch you either have to move the switch up a bit (only if possible - I don't know your printer) or lower the bed.

If you use a probe you adjust the offsets.