Problems with SSL on OctoPi

get 404 or ssl certificate problem when trying to access OctoPi from the internet also trying to using OctoPod and Bed, nozzle, & progress works remotely but no video feed because of same error reported above.

What did you already try to solve it?
Tried opening ports on my Router but no avail it seems to be some type of certificate error after an upgrade of Octopi.

Logs (octoprint.log, serial.log or output on terminal tab at a minimum, browser error console if UI issue ... no logs, no support!)
Not really sure how to do that

Additional information about your setup (OctoPrint version, OctoPi version, printer, firmware, browser, operating system, ... as much data as possible)

Raspberry Pi B+ OctoPrint version 1.3.12 WAN link to Pi REDACTED-LINK

thanks in advance for any help

Firstly, I redacted the link you posted since that would just open you up to all kinds of abuse. Secondly, opening up your OctoPrint instance to the Internet isn't recommended at all since someone else could burn your house down or extrude an entire roll of filament for you.

SSL doesn't mean others-can't-access-your-installation. It just means that the client/server conversation is encrypted to prevent eavesdropping.

Search the forum here for "safe remote access" and read the many threads on the subject. When you're certain that you're doing this correctly, then read this.


ok thanks I'll have a look, it was working before and then stopped for some reason, I'm trying to avoid installing everything from scratch again.
Thanks for the redact and the advice.