πŸ‡ΊπŸ‡¦ We stand with Ukraine! πŸ‡ΊπŸ‡¦

Prusa MINI+ "Could not write to serial port"

What is the problem?

When I try to connect to my Prusa MINI+ through Octoprint, I get a message "Could not write to serial port" when using "/dev/ttyAMA0". Setting all options to AUTO gives me a message "No serial port found".

What did you already try to solve it?

I have a RPi 3B running the latest stable version of Octoprint. I have tried adding serial ports:

  • /dev/ttyACA0
  • /dev/ttyAMA0 - only this one seems to accomplish anything

I ran through the OctoPrint can't connect to my printer help page. When I view the results of the dmesg command in terminal, I don't find any similar lines. I only find a single reference to ttyAMA0, but it's not in reference to USB.

Does that mean the correct serial port is just not exposed at all?

Have you tried running in safe mode?

Yes. I get the same results.

Did running in safe mode solve the problem?

No.

Systeminfo Bundle

Uploaded (note - Mac/Safari does not create a Zip, so the files cannot be uploaded)

Additional information about your setup

OctoPrint version: 1.8.1
OctoPi version: 0.18.0
printer: Prusa MINI+
firmware: 4.3.4
browser: Safari, Chrome
operating system: macOS 12.13.1; Windows 10
RPi: Raspberry Pi 3 Model B Rev 1.2
octoprint-systeminfo-20220616184504.zip (371.5 KB)

Did you use OctoPi to setup the Raspberry Pi, or another type of installation?

As for the logs it's OctoPi:

|  plugins:
|    pi_support:
|      model: Raspberry Pi 3 Model B Rev 1.2
|      octopi_version: 0.18.0
|      octopiuptodate_build: 0.18.0-1.8.1-20220524101555
|      throttle_state: '0x0'

Make sure it is a data USB cable. 8 times out 10 those micro USBs are power only.

I used the Raspberry PI imager, pointed at from this link:
https://octoprint.org/download/

I've literally tried 8 different USB cables. I can't verify whether any individual cable is for data or not, but given my other devices, at least one should be.
I'll do what I can to run some verifying tests and even purchase a dedicated cable

So, in spite of my 8 different USB micro cables, I purchased a cable online that claimed to be for data...

...and it worked the first try. :grumble: Thank you for the push in a direction I didn't want to believe.

1 Like